Serial Connection to Arduino

Create issue
Issue #14 new
Jeff Dorman created an issue

I've been following the resolution of Issue #4 (seestar2_lib) and have had some new issues and some similar issues in my attempts to get my See Star System up and running.

New Issue: When compiling the sketch in Arduino IDE environment, I ran into an issue that both ports.h and atmega328pwr.h defined the class MilliTimer. My code wouldn't compile. I removed the instance in atmega328pwr.h and then added "#include <Ports.h>" in atmega328pwr.h so that code had access to the other instance of the class MilliTimer. Not sure if this is an error in the code or just something I'm missing becuase of my lack of knowledge of Arduino programming.

Already posted Issue: I am currently stuck at the same spot that Jonas describes (thanks a million for the documentation Jonas) in his second post from April 9, 2016. I am able to compile the code and load it on the Arduino Pro Mini. But, when I input text, it echo's back bad data. I verified with a simple echo script that I found on the internet that this only happens when the Arduino is plugged into the shield. In all instances I had a jumper on J4.

I am also only able to compile and load the code onto the Arduino Pro Mini if it is unplugged from the shield. If plugged in, I get the following error message (avrdude: stk500_getsync(): not in sync: resp=0x00). This is a pretty common code and it appears that if anything is plugged into pins 1 or 0, it is common to get this message (http://www.parkansky.com/arduino-error.htm). I get this message even with a jumper on J4.

I'm going to get a second Arduino Pro Mini to verify that my soldering of the pins isn't the issue. Anyone have any thoughts?

So a couple questions: 1) I assume that I don't need the camera and LED module plugged into the system during compilation. Do I need to have the controller shield powered up in order to compile with the Arduino plugged into the controller shield?

2) Jonas, how did you resolve the issue where the keystrokes the Arduino reads in serial mode don't correspond to what you typed? From your later entry on April 17, 2016, it seems that it just fixed itself. Or was this a jumper on J4 issue?

Thanks everyone. Really appreciate all the efforts to document the build and troubleshoot of the See Star System.

Comments (6)

  1. Chad Kecy

    Jeff - No, you don't need the camera and LED attached to compile. You could compile the code with the Arduino separate from the controller shield or attached. If it's attached, be sure to add the jumper to disable the serial port (this allows the FTDI cable to open the port to the Arduino). Thom will have to chime in on the more detailed questions on the code itself.

  2. Jonas Follesø

    Hi @jeffdorman

    Didn,t see this issue until now. And the reason I found it: I'm experiencing the same issue. I've not been able to consistently get the Arduino to a "programmable state" - i.e. where I can type commands, set interval duration etc.

    Right now It only echo back:

    Config loaded from EEPROM
    Duration 12000 sec,  3.33 hrs
    Start Delay 60 sec
    Video Duration 30 sec
    Interval between videos/images 60 sec
    Low battery threshold  12500 mV
    Start Flag is OFF
    Config Version 1.0
    
    SeeStar2, v1.0,  software by Thom Maughan
    Setup is Complete
    

    But as I type commands nothing happens (not even bad data coming back). It all seams a bit random. I have been able to get it into a "programmable" state with the shield connected. At first I though I found the "bug" and that it was related to J9 (the jumper enabling debug LEDs) - but even with no J9 jumper I'm not able to connect to it in a consistent maner.

    I have also tried using the Serial (blue/orange) wires and connect through the power module (when running of a 12V power chord, and connect the RXD/TXD wires to the FTDI cable - but without any luck).

    Right now this is my last and major issue (replacing the Arduino Pro solved the issues I had with turning on/off GoPro power).

  3. Jonas Follesø

    If I type "help" nothing happens (i.e. nothing is echoed back). If I type "HELP" I get back "What?" - which is the default handler for unrecognized command...

  4. Jeff Dorman reporter

    I am still unable to compile and load the code onto the Arduino if it is not hooked into the controller shield. I get the same error message that I wrote in my 2016-07-06 post if I have it plugged in. But I can compile it while disconnected, then connect to controller shield and issue commands through the FTDI cable.

    I never was able to the 5 volt Arduino Pro-Mini to work. I purchased a 3.3 volt APM and (after switching the jumper on the controller shield) it all is working fine. I can issue commands, change parameters, set dates/time, start and stop the program, etc.

    Also using a Mac and issuing commands via the "Serial Monitor" interface of the Arduino environment. My issue now is getting the shutter to release and take a picture. I will create a new thread so as not to mix topics on this one.

  5. Jeff Dorman reporter

    I was doing some testing of my system yesterday (which was functioning the day before) and when I hooked up the FTDI cable, I was unable to communicate with the Arduino Pro Mini (set parameters, etc). The APM would recognize that I sent something, but if I typed "menu" it would receive random letters/symbols. Something was being lost in translation.
    The only thing I had changed was I had disconnected the J9 jumper that enables the LED lights. When I put the jumper back on, the commands I sent were recognized. Jonas mentions the J9 jumper as a potential issue above and I want to highlight that I had the same issue. Also using a Mac and issuing commands via "Serial Monitor" interface of the Arduino environment.

  6. Log in to comment