Script on GoPro SD Card not running

Create issue
Issue #15 new
Jeff Dorman created an issue

I've run into an issue getting the GoPro I'm using (Hero3+ Black) to recognize the script that I've saved in the root folder of the SD Card. I initially tried to get it to run while hooked up to the SeeStar battery and light source (the camera turned on and off, but no image was taken). To simplify things, I've isolated the camera from the rest of the system and am now just attempting to get the script to run when I turn on the camera. Power source is the standard GoPro battery.

Background information: I am using a Hero3+ Black that is running firmware 'HD3.11.02.00'. I'm trying the script on a SanDisk Extreme 64GB MicroSD XC card (UHS speed rating of 3) which is on the "approved list" from GoPro.

The code I'm trying is simple: sleep 5 t app button shutter PR sleep 10 poweroff yes reboot yes

Things I've tried: - I've checked the code for carriage returns and they don't appear to be there. I've written it in 'vi' with 'fileformats' set to unix, and in TextWrangler saving the file in unix format just to be sure. As well as downloaded code written by others (http://tools.cam-do.com/SOBM/) and copied it directly to the root folder. - I've formatted the cards using a SD formatting program (not the GoPro "erase" function) before using them to make sure they were "clean". - I've tried a Lexar 633x 16GB SD card that I had on hand.

Anyone had any issues like this? Anyone have any solutions? Or, it might be helpful if you have gotten this working, what were the parameters that worked for you? Camera model, firmware version, SD Card type....

Thanks for any and all help.

Comments (1)

  1. Jeff Dorman reporter

    Update:
    I tried the above script on a few different brands/types of SD cards and got it to run on one of them. Camera model, firmware are above.

    It worked using a Kingston microSDHC 8GB Class 4

    It did not work using a SanDisk microSDHC 8GB Class 2, SanDisk Extreme microSDXC 64GB UHS-1/U3, Lexar 633x microSDHC 16GB UHS-1/U1 . Not sure if this is a formatting issue? I tried formatting these cards using a SD formatting program and also just formating them on the GoPro using the "erase function".

    If your system is up and running it would be good to know what camera model, firmware, and microSD cards you are using. I'd like to get a 32GB or 64GB card working for deployment.

  2. Log in to comment