select timout

Create issue
Issue #7 new
Michael Backus repo owner created an issue

When I run cv with my WiFi module plugged in, I get a select timeout error after a few seconds. I'm not sure if this is because of the software I installed to setup the robot as an Access Point, or if it occurs whenever the WiFi module is plugged in. Either way, I suspect the cv's frame rate will need to be reduced and/or the process/thread given a low priority in order to avoid this problem.

Comments (10)

  1. Michael Backus reporter

    I had xrdp running at the time. The Beaglebone was also plugged into my router and I was accessing everything through the router, so there was no demand on the WiFi module.

    Perhaps modifying the cv file to run from the command line (without the need to be run from the Desktop), will results in less CPU consumption.

  2. Michael Backus reporter

    Reducing the FPS to 5 using

    capture.set(CV_CAP_PROP_FPS,5);
    

    did NOT solve the problem.

    I also tried setting the different options for the webcam's driver module using

    rmmod uvcvideo
    modprobe uvcvideo nodrop=1 timeout=5000 quirks=0x80
    

    with no noticeable change in performance.

  3. Michael Backus reporter

    Purchased RadiumBoard's camera cape for the BeagleBone Black. At this point in time it doesn't look like an optimal solution as I'm having trouble resolving color space issues, the board uses 3 of the pwm pins, it requires that the OS boot from the SD card (which is slower than the emmc), and the lag is well over a second. Also, it doesn't help that the board is more expensive than many cheap usb cameras.

  4. Michael Backus reporter

    Was able to stream jpgs from OpenCV through Wt to an Android tablet over a WiFi connection today. Not exactly sure why it worked. My best guess is that it was the results of a few changes I made to the camera's settings via Video4Linux. To install: apt-get install v4l-utils I made changes to the camera's resolution and turned off the auto white balancing. (I actually did the latter using guvcview, but it appears to be possible to do the same using v4l2-ctl commands). The other possibilities include using a newer image and changing how Wt is getting the message to the table (no more polling-it's a server push everytime the image is created).

  5. Log in to comment