1. medoc
  2. recoll
  3. Issues
Issue #115 resolved

recollindex crashing

Anonymous created an issue

Updating the database crashed from the GUI, so I ran recollindex from a terminal. It threw the following errors:

:2:../internfile/mh_html.cpp:109:textHtmlToDoc: final transcode had 53 errors for [unknown] :2:../internfile/mh_html.cpp:109:textHtmlToDoc: final transcode had 15 errors for [unknown] :2:../internfile/mh_html.cpp:109:textHtmlToDoc: final transcode had 1 errors for [unknown] buffer overflow detected : recollindex terminated ======= Backtrace: ========= /lib/libc.so.6(fortify_fail+0x37)[0x7fed6a655d27] /lib/libc.so.6(+0x100be0)[0x7fed6a654be0] /lib/libc.so.6(+0x100049)[0x7fed6a654049] /lib/libc.so.6(_IO_default_xsputn+0xcc)[0x7fed6a5cb31c] /lib/libc.so.6(_IO_vfprintf+0x1dc1)[0x7fed6a59c471] /lib/libc.so.6(vsprintf_chk+0x99)[0x7fed6a6540e9] /lib/libc.so.6(__sprintf_chk+0x7f)[0x7fed6a65402f] recollindex[0x42bd49] recollindex[0x457ac6] recollindex[0x44512d] recollindex[0x4450a1] ======= Memory map: ======== 00400000-004b6000 r-xp 00000000 fc:02 430696 /usr/bin/recollindex 006b5000-006b6000 r--p 000b5000 fc:02 430696 /usr/bin/recollindex 006b6000-006c4000 rw-p 000b6000 fc:02 430696 /usr/bin/recollindex 006c4000-006c6000 rw-p 00000000 00:00 0 0171f000-02597000 rw-p 00000000 00:00 0 [heap] 7fed68fc7000-7fed6925b000 rw-p 00000000 00:00 0 7fed694ef000-7fed694f2000 r-xp 00000000 fc:02 433799 /usr/lib/gconv/UTF-16.so 7fed694f2000-7fed696f1000 ---p 00003000 fc:02 433799 /usr/lib/gconv/UTF-16.so 7fed696f1000-7fed696f2000 r--p 00002000 fc:02 433799 /usr/lib/gconv/UTF-16.so 7fed696f2000-7fed696f3000 rw-p 00003000 fc:02 433799 /usr/lib/gconv/UTF-16.so 7fed696f3000-7fed696ff000 r-xp 00000000 fc:02 435217 /lib/libnss_files-2.11.1.so 7fed696ff000-7fed698fe000 ---p 0000c000 fc:02 435217 /lib/libnss_files-2.11.1.so 7fed698fe000-7fed698ff000 r--p 0000b000 fc:02 435217 /lib/libnss_files-2.11.1.so 7fed698ff000-7fed69900000 rw-p 0000c000 fc:02 435217 /lib/libnss_files-2.11.1.so 7fed69900000-7fed6990a000 r-xp 00000000 fc:02 435220 /lib/libnss_nis-2.11.1.so 7fed6990a000-7fed69b09000 ---p 0000a000 fc:02 435220 /lib/libnss_nis-2.11.1.so 7fed69b09000-7fed69b0a000 r--p 00009000 fc:02 435220 /lib/libnss_nis-2.11.1.so 7fed69b0a000-7fed69b0b000 rw-p 0000a000 fc:02 435220 /lib/libnss_nis-2.11.1.so 7fed69b0b000-7fed69b22000 r-xp 00000000 fc:02 435213 /lib/libnsl-2.11.1.so 7fed69b22000-7fed69d21000 ---p 00017000 fc:02 435213 /lib/libnsl-2.11.1.so 7fed69d21000-7fed69d22000 r--p 00016000 fc:02 435213 /lib/libnsl-2.11.1.so 7fed69d22000-7fed69d23000 rw-p 00017000 fc:02 435213 /lib/libnsl-2.11.1.so 7fed69d23000-7fed69d25000 rw-p 00000000 00:00 0 7fed69d25000-7fed69d2d000 r-xp 00000000 fc:02 435205 /lib/libnss_compat-2.11.1.so 7fed69d2d000-7fed69f2c000 ---p 00008000 fc:02 435205 /lib/libnss_compat-2.11.1.so 7fed69f2c000-7fed69f2d000 r--p 00007000 fc:02 435205 /lib/libnss_compat-2.11.1.so 7fed69f2d000-7fed69f2e000 rw-p 00008000 fc:02 435205 /lib/libnss_compat-2.11.1.so 7fed69f2e000-7fed69f33000 r-xp 00000000 fc:02 401268 /usr/lib/libXdmcp.so.6.0.0 7fed69f33000-7fed6a132000 ---p 00005000 fc:02 401268 /usr/lib/libXdmcp.so.6.0.0 7fed6a132000-7fed6a133000 r--p 00004000 fc:02 401268 /usr/lib/libXdmcp.so.6.0.0 7fed6a133000-7fed6a134000 rw-p 00005000 fc:02 401268 /usr/lib/libXdmcp.so.6.0.0 7fed6a134000-7fed6a136000 r-xp 00000000 fc:02 401266 /usr/lib/libXau.so.6.0.0 7fed6a136000-7fed6a336000 ---p 00002000 fc:02 401266 /usr/lib/libXau.so.6.0.0 7fed6a336000-7fed6a337000 r--p 00002000 fc:02 401266 /usr/lib/libXau.so.6.0.0 7fed6a337000-7fed6a338000 rw-p 00003000 fc:02 401266 /usr/lib/libXau.so.6.0.0 7fed6a338000-7fed6a353000 r-xp 00000000 fc:02 401270 /usr/lib/libxcb.so.1.1.0 7fed6a353000-7fed6a552000 ---p 0001b000 fc:02 401270 /usr/lib/libxcb.so.1.1.0 7fed6a552000-7fed6a553000 r--p 0001a000 fc:02 401270 /usr/lib/libxcb.so.1.1.0 7fed6a553000-7fed6a554000 rw-p 0001b000 fc:02 401270 /usr/lib/libxcb.so.1.1.0 7fed6a554000-7fed6a6d1000 r-xp 00000000 fc:02 435218 /lib/libc-2.11.1.so 7fed6a6d1000-7fed6a8d0000 ---p 0017d000 fc:02 435218 /lib/libc-2.11.1.so 7fed6a8d0000-7fed6a8d4000 r--p 0017c000 fc:02 435218 /lib/libc-2.11.1.so 7fed6a8d4000-7fed6a8d5000 rw-p 00180000 fc:02 435218 /lib/libc-2.11.1.so 7fed6a8d5000-7fed6a8da000 rw-p 00000000 00:00 0 7fed6a8da000-7fed6a8f0000 r-xp 00000000 fc:02 391695 /lib/libgcc_s.so.1 7fed6a8f0000-7fed6aaef000 ---p 00016000 fc:02 391695 /lib/libgcc_s.so.1 7fed6aaef000-7fed6aaf0000 r--p 00015000 fc:02 391695 /lib/libgcc_s.so.1 7fed6aaf0000-7fed6aaf1000 rw-p 00016000 fc:02 391695 /lib/libgcc_s.so.1 7fed6aaf1000-7fed6ab73000 r-xp 00000000 fc:02 435201 /lib/libm-2.11.1.so 7fed6ab73000-7fed6ad72000 ---p 00082000 fc:02 435201 /lib/libm-2.11.1.so 7fed6ad72000-7fed6ad73000 r--p 00081000 fc:02 435201 /lib/libm-2.11.1.so 7fed6ad73000-7fed6ad74000 rw-p 00082000 fc:02 435201 /lib/libm-2.11.1.so 7fed6ad74000-7fed6ae6a000 r-xp 00000000 fc:02 391697 /usr/lib/libstdc++.so.6.0.13 7fed6ae6a000-7fed6b06a000 ---p 000f6000 fc:02 391697 /usr/lib/libstdc++.so.6.0.13 7fed6b06a000-7fed6b071000 r--p 000f6000 fc:02 391697 /usr/lib/libstdc++.so.6.0.13 7fed6b071000-7fed6b073000 rw-p 000fd000 fc:02 391697 /usr/lib/libstdc++.so.6.0.13 7fed6b073000-7fed6b088000 rw-p 00000000 00:00 0 7fed6b088000-7fed6b08a000 r-xp 00000000 fc:02 435216 /lib/libdl-2.11.1.so 7fed6b08a000-7fed6b28a000 ---p 00002000 fc:02 435216 /lib/libdl-2.11.1.so 7fed6b28a000-7fed6b28b000 r--p 00002000 fc:02 435216 /lib/libdl-2.11.1.so 7fed6b28b000-7fed6b28c000 rw-p 00003000 fc:02 435216 /lib/libdl-2.11.1.so 7fed6b28c000-7fed6b2a4000 r-xp 00000000 fc:02 435212 /lib/libpthread-2.11.1.soAborted

Comments (15)

  1. Jay Schieber

    Yeah, I already tried adding that PPA to get a more recent version of recoll. However, it is held back because of an unmet dependency on a more recent version of xapian. I tried adding a repo for xapian, but it did not work.

  2. Jay Schieber

    After a few more attempts to use synaptic to resolve the dependencies, 1.18 has finally been installed. I am running recollindex from a terminal now. It seems to be updating the database from the old version, so it might be awhile before I know if things are working OK. I will let you know when it finishes running.

  3. medoc repo owner

    Glad you could solve the dependancy issues. As the previous version was quite far away, I think that it would be better to completely destroy the index (rm -rf ~/.recoll/xapiandb) and rebuild it. Just updating should be ok to check that the crash is gone though.

  4. Jay Schieber

    I am not sure if recoll has created another problem. After getting it to work and indexing all of my files, I updated my linux kernel and rebooted. Now synaptic crashes. If I open Adept and try to do a search, I get an error message: "Couldn't detect type of database." I assume this is also what is crashing synaptic. Could this somehow have been caused by recoll?

  5. medoc repo owner

    Not by recoll itself, but I think that I heard that there were compatibility issues between synaptic and newer versions of Xapian. If I remember well, this only affects one of the kinds of searches, and synaptic remains mostly usable.

    If this is not tolerable, the only approach I can think of would be to restore a version of Xapian with which synaptic works, and compile Recoll locally (either with the older system Xapian or by installing a newer Xapian in /usr/local, then using the same prefix for Recoll).

  6. Jay Schieber

    I think that you are right. If I use "Quick Search", synaptic crashes. However, the search tool works fine. Probably the simplest thing to do is avoid quick search until Synaptic and Xapian learn to play nicely together again.

  7. medoc repo owner

    For your information and as far as I know, the problem does not exist with recent Ubuntu releases, specifically the newer LTS release, 12.04 Precise.

    Given that support for desktop Lucid ends next April, I would not try to hold my breath until the Lucid Synaptic is fixed...

  8. Jay Schieber

    It is good to hear that it should work with 12.04. I was waiting until I had no critical deadlines before I updated to that LTS (which should be next week).

    I installed recoll on two different desktops that I keep synced with Unison (one at home, one at work). I saw a 2GB file was trying to sync from one to the other, and after some investigating, discovered that on one of the boxes recoll was using ~/.recoll/xapiandb as the directory (logical) and the other was using ~/Documents (which makes no sense). I can't imagine how that difference came about. At any rate, it was easy to fix.

  9. Log in to comment