1. medoc
  2. recoll
  3. Issues
Issue #147 resolved

remotely mounted file system indexed but shows no query results

created an issue

(all this worked with version 1.8x)

I have mounted remote filesystem via cifs: there I have some txt/pdf/doc files. I added the path to the searchdirectories and it starts indexing (which I can see at the bottom left in recolls window) If I now query for some word which I know is at least in a couple of pdfs I do not get any results. If I go for refreshing the index I get:

indexing: refreshing (1598/143948/1554507) indexing: runs closing indexing: surveiing /path/to/remote/directory/remote.file.name

so my guess is that the last number is the documents which are in the index, the middle one shows the progress and the left one is altered documents (1598/143948/1554507)?

if I query again for the same term I again get no results. I know this all worked with 1.8x with the same remotely mounted filesystem and the same documents.

Here some more background information

cat /etc/fstab // /home/fs cifs noperm,auto,user=Robin,password=XYZ,gid=users 0 0

mount gives // on /home/fs type cifs (rw,relatime,vers=1.0,sec=ntlmssp,cache=strict,unc=\FILESERVER\fs,username=Robin,domain=ABC,uid=0,noforceuid,gid=100,forcegid,addr=,file_mode=0755,dir_mode=0755,nounix,noperm,rsize=61440,wsize=65536,actimeo=1)

ls -l /home rwxr-xr-x 2 root users 4096 28. Mai 19:18 fs ls -l /home/fs drwxr-xr-x 2 limo users 16384 25. Apr 11:53 User ls -l /home/fs/REMOTEDATAA drwxr-xr-x 0 limo users 0 8. Mai 10:59 disc2

cat recoll.conf ... unac_except_trans = ää Ää öö Öö üü Üü ßss œoe Œoe æae Æae fifi\ flfl topdirs = /home/fs/REMOTEDATAA /home/fs/REMOTED\W ATAB indexstemminglanguages = english german german2

cat missing empty file

ls -l xapiandb ls -l insgesamt 2446540 -rw-r--r-- 1 limo users 0 7. Jun 09:16 flintlock -rw-r--r-- 1 limo users 28 5. Jun 17:04 iamchert -rw-r--r-- 1 limo users 9601 7. Jun 09:16 position.baseA -rw-r--r-- 1 limo users 9601 7. Jun 09:20 position.baseB -rw-r--r-- 1 limo users 627834880 6. Jun 23:21 position.DB -rw-r--r-- 1 limo users 12443 7. Jun 09:16 postlist.baseA -rw-r--r-- 1 limo users 12443 7. Jun 09:20 postlist.baseB -rw-r--r-- 1 limo users 814104576 7. Jun 09:20 postlist.DB -rw-r--r-- 1 limo users 4968 7. Jun 09:16 record.baseA -rw-r--r-- 1 limo users 4968 7. Jun 09:20 record.baseB -rw-r--r-- 1 limo users 324272128 7. Jun 09:15 record.DB -rw-r--r-- 1 limo users 14 7. Jun 09:20 synonym.baseA -rw-r--r-- 1 limo users 14 7. Jun 09:16 synonym.baseB -rw-r--r-- 1 limo users 16384 7. Jun 09:15 synonym.DB -rw-r--r-- 1 limo users 11296 7. Jun 09:16 termlist.baseA -rw-r--r-- 1 limo users 11296 7. Jun 09:20 termlist.baseB -rw-r--r-- 1 limo users 738902016 7. Jun 09:15 termlist.DB

Comments (4)

  1. medoc repo owner


    please follow the instructions here to check why some files are not indexed.

    Use absolute path to all recollindex commands because of the 1.19.3 relative paths bug

    Please send me the log by email: jf at dockes.org, or attach it as a file here, pasting it inside the comments results in garbled display.

    About the status bar display, the three numbers are, afaik, the count of documents updated, the count of files scanned (even if they did not need updating) and the total count of documents in the index. This is not extremely useful, just to have something moving while the indexer is scanning a big composite file.

  2. Log in to comment