Commits

Michael Forbes committed 4f16159

Removed optional requirements... these should not break the install.

  • Participants
  • Parent commits 505e7c5

Comments (0)

Files changed (1)

 
       # Project uses sphinx for documentation, so ensure that we have
       # docutils:
-      install_requires = [
-        "EPD>=7.3",
-        "zope.interface>=3.8.0",
-        ],
+      #
+      # I don't really depend on EPD, so do not include that here until a way is
+      # found to make it only a warning.
+      install_requires = [],
 
       extras_require = {
-        'cvxopt':  ["cvxopt"],
-        'ode': ["scikits.bvp1lg>=0.2"],
-        'doc': ["Sphinx>=1.1.2", "sphinxcontrib-zopeext>=0.2"],
-        },
+          'all': ["EPD>=7.3"],
+          'cvxopt':  ["cvxopt"],
+          'ode': ["scikits.bvp1lg>=0.2"],
+          'doc': ["zope.interface>=3.8.0", 
+                  "Sphinx>=1.1.2",
+                  "sphinxcontrib-zopeext>=0.2"],
+      },
       
       # Extension modules
       ext_modules = [