Commits

Michał Górny committed 3453afa

Paludis: refuse running with <paludis-0.64.2.

Comments (0)

Files changed (1)

gentoopm/paludispm/__init__.py

 
 import functools, paludis
 
+try:
+	paludis.PackageDepSpec.slot
+except (NameError, AttributeError):
+	raise ImportError('paludis version too old (at least 0.64.2 required)')
+
 from gentoopm.basepm import PackageManager
 from gentoopm.paludispm.atom import PaludisAtom
 from gentoopm.paludispm.config import PaludisConfig