1. michael b
  2. fsgamer
  3. Issues
Issue #28 new

When attempting to run a game: "OSError Permission denied"

Bangbang Pow
created an issue

Did all the installation instructions but still got the following when trying to start a game....steam in this case

Tried with "sudo" and "gksudo" just to be sure.

Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/fsgamer/FsgamerWindow.py", line 128, in on_giant_play_button_clicked self.current_app.run_outer(replace=True) File "/usr/lib/python2.7/dist-packages/fsgamer/fsgamer_app.py", line 209, in run_outer utils.shell_run(e, replace=True) File "/usr/lib/python2.7/dist-packages/fsgamer/utils.py", line 282, in call os.execv(path, [path]) OSError: [Errno 13] Permission denied

Comments (4)

  1. michael b repo owner

    Hm, weird.

    An earlier bug I ran into re. permissions (which I thought I had fixed for 1.1) was reproduced by running as one user and then another on the same machine without reboot. Is that what you did here? (FSGamer makes little shell scripts in /tmp/ and so if another user has run it, it might have left some random scripts there)

  2. Bangbang Pow reporter

    I know why it did that then.... my /tmp is on RAM... Is there anything I can do? I noticed that even with root i don't have permissions to modify /tmp ... Else i'll just remove my /tmp from RAM

    I'll try removing my /tmp from RAM see if it solves the issue ... i'll report back

  3. Log in to comment