Commits

mickael9 committed a4757d3

Compatibility with old launcher again.

  • Participants
  • Parent commits 230634e
  • Branches beta1.3

Comments (0)

Files changed (2)

 urls = (
     # login.minecraft.net
     '/', 'getversion',
+    '/game/getversion.jsp', 'getversion',
 
     # server auth
     '/game/joinserver.jsp', 'joinserver',
                 password=None,
                 version=None)
 
-        if int(i.version) < config.LAUNCHER_VER:
+        try:
+            if int(i.version) not in config.LAUNCHER_VERS:
+                return "Old version"
+        except ValueError:
             return "Old version"
 
         try:
 SALT = ''
 CLIENT_VER = '1295618277000' # see ~/.minecraft/bin/version
-LAUNCHER_VER = 13
+LAUNCHER_VERS = (12, 13)
 ALLOWED_IPS = ('127.0.0.1',) # these server IPs are allowed to use this master