Iterative mapping stuck after first iteration

Issue #15 new
Ilya Flyamer
created an issue

Hi, I am trying to use hiclib for analysis of Hi-C data. I have successfully used it in the past, but now I have a problem with mapping reads to a genome. After the first iteration and creation of fastq.gz file with reads for the second iteration (it's size stops rising) the programme gets stuck. You can see three terminal windows here, with the running programme, top and iotop. Python uses a lot of memory, but there is no processor usage. And it doesn't write anything to disk, though reads something. And this lasts for over 1hr. I tried with both gzip and pigz, looks the same. I believe this is not normal behaviour?
Log of what you see in the first terminal is attached.

And this is how I run mapping:

mapping.iterative_mapping(
    bowtie_path='/usr/bin/bowtie2',
    bowtie_index_path='/media/ilya/SSD/genomes/Dd/index/Dd',
    fastq_path='../fastq/repA/read1.fastq.bz2',
    out_sam_path='../bams/repA/forw.bam',
    min_seq_len=20,
    len_step=5,
    nthreads=8,
    #max_reads_per_chunk = 10000000,  #optional, on low-memory machines
    temp_dir='tmp',  # optional, keep temporary files here
    bowtie_flags='--very-sensitive',
    bash_reader='bzcat')

I am running Ubuntu 14.04 on a computer with 8Gb RAM, i7-4702MQ processor and use the latest mirnylib/hiclib (installed both with pip install bitbucket... yesterday).

Best,
Ilya

Comments (11)

  1. Ilya Flyamer reporter

    Hi Maksim,

    No, I used a much earlier version which I downloaded around December 2013. I still have it, and will try to just use it now, guess the result of mapping won't be any different anyway :)

    So yes, I suppose this bug was introduced at some point between that time and now. Though now the reference genome is different, if it could have any influence on the issue, which I suppose it can't.

    Ilya

  2. Log in to comment