Commits

Anonymous committed 7159086

remove unused requirement for migrate, make elixir a seperate install since only tests require it

Comments (0)

Files changed (3)

 miruku Changelog
 ================
+(**mixedpuppy**)
+* Removed unused requirement for sqlalchemy-migrate
+* Removed requirement for Elixir (still need seperate install for tests)
+* Fixed use with declarative Base
+* Other minor bug fixes
+
 0.1.2 (**tip**)
 * Edited commands to accept a 'format' kwarg and (optionally) to
   collect up the output in a list, the latter bound to the 

miruku/commands.py

 from sqlalchemy.util import pickle
 import sqlalchemy.exceptions
 
-from migrate.changeset.databases.visitor import get_engine_visitor
-
 from miruku import schema
 from miruku.diff import MetaDiff
 from miruku.util import eval_import, cleanup_elixir
     author="Olli Wang",
     author_email="olliwang@ollix.com",
     url="http://trac.ollix.org/miruku/",
-    # install_requires=["SQLAlchemy>=0.5.3",
-    #                   "sqlalchemy-migrate>=0.5.3",
-    #                   "elixir==0.6.1"],
-    install_requires=["SQLAlchemy>=0.5.8",
-                      "sqlalchemy-migrate>=0.5.4",
-                      "elixir>=0.7"],
-    # install_requires=["SQLAlchemy==0.6beta2dev",
-    #                   "sqlalchemy-migrate>=0.5.5",
-    #                   "elixir>=0.8.0dev"],
+    install_requires=["SQLAlchemy>=0.5.8"],
     packages=find_packages(exclude=['ez_setup']),
     include_package_data=True,
     zip_safe=False,