1. Manfred Moitzi
  2. bintrees
  3. Issues
Issue #4 resolved

Problem copying FastRBTree?

created an issue

There seems to be an issue with copying a FastRBTree through the tree.copy() method; but I'm not sure the problem is there. I get a segmentation violation and can't exactly pinpoint where it happens; for example, for exactly the same data it happens at different places if I run my code through the IDE (Eclipse PyDev) or from the command line. Also, if I use the PyDev debugger, the issue doesn't happen. If I use RBTree, the issue doesn't happen.

Attached the operations that are done on the tree if I use the IDE to run the code.

Comments (2)

  1. Peter Mell

    I'm experiencing a similiar problem with FastRBTree except I'm not using tree.copy(). My code works perfectly using RBTree but crashes with FastRBTree after working for a little while. I'm creating tens of thousands of trees at a time and performing heavy manipulations. I've tried to come up with a simple example to highlight the error but haven't yet been able to do it. I'll keep trying. Thanks in advance for your help!!

  2. Log in to comment