Commits

Mike Podonyi committed bf76abe

fix tests for ASP.NET

Comments (0)

Files changed (3)

src/Empi.Camino.Test/SettingsTest.cs

 		public void MyDbIdTest()
 		{
             string actual = TestSettings.GetTestSettings.MyDbId;
-			Assert.AreEqual<string>("Logrono", actual);
+			Assert.AreEqual<string>("dev", actual);
 		}
 
 		[TestMethod()]
 		public void MetaDataBaseConnectionStringTest()
 		{
             string actual = TestSettings.GetTestSettings.MetaDataBaseConnectionString;
-			Assert.AreEqual<string>("sdafgreg", actual);
+			Assert.AreEqual<string>(@"Data Source=MPODONYI-PC\SQLEXPRESS;Initial Catalog=MetaDb;Integrated Security=True", actual);
 		}
 
         [TestMethod()]
         public void MyDbStateTest()
         {
             string actual = TestSettings.GetTestSettings.MyDbState;
-            Assert.AreEqual<string>("Dev", actual);
+            Assert.AreEqual<string>("dev", actual);
         }
 
         [TestMethod()]

src/LocalTestRun.testrunconfig

 <?xml version="1.0" encoding="UTF-8"?>
 <TestRunConfiguration name="Local Test Run" id="22ff85a5-dbcb-43ea-a666-19658d911eff" xmlns="http://microsoft.com/schemas/VisualStudio/TeamTest/2006">
   <Description>This is a default test run configuration for a local test run.</Description>
-  <Hosts>
+  <Hosts type="ASP.NET">
     <AspNet name="ASP.NET" executionType="WebDev" urlToTest="http://localhost:3338/">
       <DevelopmentServer pathToWebSite="D:\Development\camino-unstable\src\Logrono" webApplicationRoot="/" />
     </AspNet>

src/Logrono/Web.config

 	<appSettings/>
 	<!-- Mike START -->
 	<empi.camino>
-		<metadb connectionstringname="fire"/>
-		<mydb id="Logrono" state="Dev"/>
+        <metadb connectionstringname="fire" />
+        <mydb id="dev" state="dev"/>
 	</empi.camino>
 	<connectionStrings>
-		<add connectionString="sdafgreg" name="fire"/>
+        <add connectionString="Data Source=MPODONYI-PC\SQLEXPRESS;Initial Catalog=MetaDb;Integrated Security=True" name="fire"/>
 	</connectionStrings>
 	<!-- Mike END -->
 	<system.web>