PyPI release 2018.06.05 has the wrong filename

Create issue
Issue #285 resolved
Eli Schwartz created an issue

The download name uses 2018.06.05a instead. I think this might be why pip install --user --upgrade regex will not retrieve the new version, saying:

Requirement already up-to-date: regex in /usr/lib/python3.6/site-packages (2018.2.21)

For distro packaging purposes, we could use 2018.06.05a as the version, which matches the filename and internal directory structure so the file downloads and builds okay, but then the setup.py tells it to install 2018.06.05 as far as the .egg-info is concerned.

Comments (2)

  1. Log in to comment