Commits

Marc Abramowitz  committed 29841c5

setup.py: Require argparse for PY3 < 3.2

E.g.: python3.1; noticed py31 failure while running tox for six

  • Participants
  • Parent commits 26d43b6
  • Branches require_argparse_for_py3_lt_32

Comments (0)

Files changed (1)

 long_description = open("README.rst").read()
 def main():
     install_requires = ["py>=1.4.20"]
-    if sys.version_info < (2,7):
+    if (sys.version_info < (2,7) or
+        sys.version_info > (3, ) and sys.version_info < (3, 2)):
         install_requires.append("argparse")
     if sys.platform == "win32":
         install_requires.append("colorama")