Pull requests

#1 Declined
Repository
Branch
issue_19
Repository
Branch
default

Put six.moves modules in sys.modules so that they're importable (fixes

Author
  1. Marc Abramowitz
Reviewers
Description

Here's an attempt to fix issue #19.

marca@marca-mac:~/dev/hg-repos/six_msabramo$ python
Python 2.7.3 (v2.7.3:70274d53c1dd, Apr  9 2012, 20:52:43)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import six.moves.configparser
>>> import six.moves.queue
>>> six.moves.configparser
<module 'ConfigParser' from '/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ConfigParser.pyc'>
>>> six.moves.queue
<module 'Queue' from '/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/Queue.pyc'>

Comments (1)