Can't create table

Issue #91 invalid
Lee Gary created an issue

OpenBiblio was upgraded for an elementary / middle school library center from 0.6 to 0.7.1. I am getting the following error and don't know how to resolve it.

"Please give all the information on this page to your support personnel.

Query select * from biblio_copy_fields where bibid=1114 and copyid=1 failed. The DBMS said this:

Table 'flcclear_libr01.biblio_copy_fields' doesn't exist."

I wasn't the person who performed the upgrade so I don't know what steps were done in the installation. I did see the 0.7.0 version install folder. I am thinking a step was missed to convert the old database to the new database layout and naming format.

I was asked to assist the school because I have computer programming background but I am unfamiliar with this system. So please have patients when giving a solution.

Here is some info I know that might be helpful (going from memory I apologize):
MySQL version = 5.4
PHP version = 5.3 or 5.5


Comments (15)

  1. Hans van der Weij

    The message about the the table that does not exist is exactly what you can expect when step 5 from the instruction Updating from a previous version of OpenBiblio is missed. So you can simply solve your issue by running /openbiblio/install/
    I suppose the install folder is still present, because the suggestion to remove it is step 6. And step 4 (database backup) is still a good idea.

    For more detail open the file install_instructions.html in the root of the openbiblio folder.

  2. Hans van der Weij

    Simply run /openbiblio/install/index.php

    (upgrading involves sql scripts from the folders /openbiblio/install/x.x.x/sql/ but also commands from /classes/UpgradeQuery.php)

  3. Hans van der Weij

    I guess the instructions for upgrading are more clear when they state that the conversion tool should be run in the web browser!

  4. Lee Gary reporter


    Thank you for the information. One final question, should I run the 0.7.0 install first to convert the databases and then run the 0.7.1 install to convert the databases again OR if I just run the install from 0.7.1 it will convert the old databases from 0.6.0 to the current format?

  5. Hans van der Weij

    I understand from your previous messages that version 0.7.1 is already copied to the webserver (you confirm this by checking the page footer from the OPAC).

    0.7.1 will convert any database version between 0.3.0 and 0.7.0 automatically, so I think you're almost done!

  6. Lee Gary reporter


    I tried to following the steps in the installation folder and follow your commands and nothing worked. Nothing worked automatically. Very frustrating and unclear.

    Are there any other suggestions? I will be unavailable today to work on the issue. But clearer step by step instructions would be really nice.

    Thank you.

  7. Lee Gary reporter


    OpenBiblio was upgraded from 0.6.0 to 0.7.1. The database was updated to 0.7.1 also.

    When I enter a book number and click checkout I get the following error:
    "Please give all the information on this page to your support personnel.

    Query select * from biblio_copy_fields where bibid=1114 and copyid=1 failed. The DBMS said this:

    Table 'flcclear_libr01.biblio_copy_fields' doesn't exist."

    I assumed the issue was due to the database wasn't successfully updated. I will check to see if I can get you access via the internet. I am not at the school right now. But I will be heading there shortly. What steps would you like for me to perform?

  8. Hans van der Weij

    If the database version in the page footer says: 0.7.1, then apparently table biblio_copy_fields (and also probably biblio_copy_fields_dm) have not been created automatically.

    Correct this outside the OpenBiblio web interface, by entering the SQL commands from the following files:


    That should fix the error from your first message.

    Also additional checks need to be done. Here's a quick check: Using the OpenBiblio Admin tab - Collections, try setting field Days Due Back to value 300. If the result is 300, I think the upgrade should be OK. If not (255?) then additional upgrade commands should be performed manually.

  9. Lee Gary reporter


    OpenBiblio version 0.7.1 database version 0.6.0.

    Is there an easy way to point to the latest database?

  10. Hans van der Weij

    Ah, the page footer still says database version 0.6.0. Then it should be easy.

    Perhaps it's best to make sure first that the folders and files as installed on the webserver are identical to those offered in our orginal 0.7.1 download file. A missing install folder and / or subfolders can break the update process. Perhaps you would like to download again and follow the instructions for updating.

    The following is taken from install_instructions.html

    1. Rename your old openbiblio installation directory so that you don't lose its contents. We'll call the old directory openbiblio-old.
    2. Copy the new openbiblio directory and all of its contents into the directory where the old openbiblio installation was.
    3. Copy the database_constants.php file from the openbiblio-old directory into the new openbiblio directory, replacing the database_constants.php file there.
    4. (let's suppose you already have a backup of the database and skip this step)
    5. (this step is rephrased)
      When you open the public catalog (OPAC) in a browser, the browser's location bar says something like http://myschool/openbiblio/opac/
      Change this to http://myschool/openbiblio/install/ and press Enter

    The resulting page should say: It looks like we need to update database version 0.6.0 to version 0.7.1

    After proceeding by pressing the button, the database should be updated.

  11. Lee Gary reporter

    Great news! It works! I figured out how to login to the host via PUTTY. Steps 1 - 4 were already completed. I logged in, changed directories to where the updated new files were located, then executed php update.php and it said the update was successful! I reloaded the program, OpenBiblio version 0.7.1 database version 0.7.1. And I ran a "transaction" and WOOHOO!!! Oh HAPPY DAY! Great way to start the weekend.

    I want to leave the issue open for a couple more days to make sure something else wasn't missed. The personnel that runs the library application will not be in until Tuesday afternoon. Thanks again for your help.

  12. Hans van der Weij

    Congratulations for finding a creative solution, and I have to thank you. I didn't know that /install/update.php runs succesfully from the command line. /install/index.php does not.

    After experimenting, I have to conclude that the database version still was 0.6.0. Perhaps there was some miscommunication, so next time I'll think about sending screendumps.

  13. Log in to comment