Commits

Yevgen Muntyan committed a288043

Remove obsolete checks for automake and autoconf versions

Comments (0)

Files changed (1)

 DIE=0
 
 #tell Mandrake autoconf wrapper we want autoconf 2.5x, not 2.13
-WANT_AUTOCONF_2_5=1
-export WANT_AUTOCONF_2_5
-version_check autoconf AUTOCONF 'autoconf2.50 autoconf autoconf-2.53' $REQUIRED_AUTOCONF_VERSION \
-    "http://ftp.gnu.org/pub/gnu/autoconf/autoconf-$REQUIRED_AUTOCONF_VERSION.tar.gz" || DIE=1
+AUTOCONF=${AUTOCONF:-autoconf}
 AUTOHEADER=`echo $AUTOCONF | sed s/autoconf/autoheader/`
 
-case $REQUIRED_AUTOMAKE_VERSION in
-    1.4*) automake_progs="automake-1.4" ;;
-    1.5*) automake_progs="automake-1.5 automake-1.6 automake-1.7 automake-1.8 automake-1.9 automake-1.10 automake-1.11" ;;
-    1.6*) automake_progs="automake-1.6 automake-1.7 automake-1.8 automake-1.9 automake-1.10 automake-1.11" ;;
-    1.7*) automake_progs="automake-1.7 automake-1.8 automake-1.9 automake-1.10 automake-1.11" ;;
-    1.8*) automake_progs="automake-1.8 automake-1.9 automake-1.10 automake-1.11" ;;
-    1.9*) automake_progs="automake-1.9 automake-1-10 automake-1.11" ;;
-    1.10*) automake_progs="automake-1.10 automake-1.11" ;;
-    1.11*) automake_progs="automake-1.11" ;;
-esac
-version_check automake AUTOMAKE "$automake_progs" $REQUIRED_AUTOMAKE_VERSION \
-    "http://ftp.gnu.org/pub/gnu/automake/automake-$REQUIRED_AUTOMAKE_VERSION.tar.gz" || DIE=1
+AUTOMAKE=${AUTOMAKE:-automake}
 ACLOCAL=`echo $AUTOMAKE | sed s/automake/aclocal/`
 
 if $want_libtool; then