Commits

Rémy HUBSCHER committed 3f7fcae

La requirements version by default

  • Participants
  • Parent commits 10d068d

Comments (0)

Files changed (3)

 *~
 *.pyc
 docs/.build
+dj_startproject.egg-info/

File dj-startproject/django-startproject.py

     import django
     assert django.VERSION[0:2] == (1, 3)
 except:
-    print >> sys.stderr, "Don't forget to install Django-1.3\n    pip install Django==1.3"
+    print >> sys.stderr, "Don't forget to install Django-1.3\n    sudo pip install Django"
     sys.exit(4)
 
 try:
     import jinja2
 except:
-    print >> sys.stderr, "Don't forget to install python-jinja2\n    sudo apt-get install python-jinja2"
-    sys.exit(4)
+    print >> sys.stderr, "Don't forget to install python-jinja2\n    sudo pip install jinja2"
+    sys.exit(5)
 
 import os
 

File dj-startproject/templates/requirements.txt.tpl

-Django==1.3
-MySQL-python==1.2.3
-PIL==1.1.7
-PyYAML==3.10
-distribute==0.6.15
-django-classy-tags==0.3.3.1
-django-floppyforms==0.4.4
-django-grappelli==2.3.3
-django-mptt==0.4.2
-wsgiref==0.1.2
-yolk==0.4.1
+Django
+MySQL-python
+PIL
+PyYAML
+distribute
+django-classy-tags
+django-floppyforms
+django-grappelli
+django-mptt
+wsgiref
+yolk