Commits

Show all
Author Commit Message Labels Comments Date
Nick Coghlan
Fix update glitch with requires.txt
Branches
avoid_side_effects
Nick Coghlan
Minimise import side effects
Branches
avoid_side_effects
Jason R. Coombs
Merge
Jason R. Coombs
Powershell isn't installed by default on Windows Server 2008. Also it's possible that Powershell is present on older systems. Now use direct detection of a Powershell executable to determine viability of that technique for a downloader. Fixes #67.
Daniel Néri
Fix spelling
Jason R. Coombs
Corrected title formatting and hyperlink to correct Sphinx errors
Jason R. Coombs
Remove linked changes file after upload and push
Jason R. Coombs
Extract bookmark name into the class
Jason R. Coombs
Encapsulate bootstrap bookmark functionality
Jason R. Coombs
Refactor for clarity
Jason R. Coombs
Use jaraco.packaging 2.0 to invoke pushing the bookmark as a separate operation from pushing the other changesets.
Jason R. Coombs
Bumped to 1.1 in preparation for next release.
Jason R. Coombs
Added tag 1.0 for changeset c385fdf1f976
Jason R. Coombs
Removed the --delete-conflicting and --ignore-conflicts-at-my-risk options, which have long been deprecated and indicated that they're not used.
Tags
1.0
Jason R. Coombs
Updated docs in Multiple Python Versions to reference supported Python versions.
Jason R. Coombs
Reorganized the documentation to cover the different launcher techniques.
Jason R. Coombs
Changed the launcher relevant environment variable to SETUPTOOLS_LAUNCHER and it now accepts different strings 'natural' and 'executable', instead of only reflecting a boolean value.
Jason R. Coombs
Updated changelog once more to provide a re-assuring narrative about the backward-incompatible changes.
Jason R. Coombs
Updated changelog to highlight backward-incompatible changes
Jason R. Coombs
Set stacklevel on DeprecationWarning for more relevant locality.
Jason R. Coombs
Added tag 1.0b3 for changeset 8a98492f0d85
Jason R. Coombs
Merge
Tags
1.0b3
Jason R. Coombs
Fix template rendering error
Jason R. Coombs
Warn when scripts are installed but PATHEXT isn't set
Jason R. Coombs
Use .pya extension instead of simply .py to avoid creating scripts that are importable as modules.
Jason R. Coombs
Remove -script scripts also
Jason R. Coombs
Normalize whitespace
Jason R. Coombs
Remove unused import
Jason R. Coombs
Reorganize imports
Jason R. Coombs
Allow the test to fail on its own merits rather than failing with a not-so-useful message; removed Python 2.3 support.
  1. Prev
  2. Next