1. Ned Batchelder
  2. coverage.py
  3. Issues
Issue #20 duplicate

python2.4.6 easy_install "Not a recognized archive type"

Anonymous created an issue

{{{ $ uname -a Linux 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 00:28:35 UTC 2009 i686 GNU/Linux

$ python2.4 -V Python 2.4.6 }}}

==== To Recreate ==== {{{

!bash

mkdir testsetup wget http://peak.telecommunity.com/dist/ez_setup.py sudo /usr/bin/python2.4 ./ez_setup.py sudo /usr/bin/easy_install-2.4 virtualenv python2.4 /usr/bin/virtualenv --no-site-packages . ./bin/easy_install 'coverage>=2.85' }}}

==== Output ==== {{{ ... Searching for coverage>=2.85 Reading http://pypi.python.org/simple/coverage/ Reading http://nedbatchelder.com/code/modules/coverage.html Reading http://nedbatchelder.com/code/coverage Best match: coverage 3.0.1 Downloading http://pypi.python.org/packages/source/c/coverage/coverage-3.0.1.tar.gz#md5=b299c33b169bd796a6186a1f0f42a7da Processing coverage-3.0.1.tar.gz error: Not a recognized archive type: /tmp/easy_install-e3Z3gA/coverage-3.0.1.tar.gz

}}}

python2.6 easy_install works just fine.

Comments (3)

  1. Log in to comment