travis-ci only runs py26 only

Issue #546 invalid
Loic Dachary
created an issue

The travis config @ travis-ci is

{
  "language": "python",
  "sudo": false,
  "python": 2.7,
  "addons": {
    "apt": {
      "sources": [
        "deadsnakes"
      ],
      "packages": [
        "python3.5",
        "python3.5-dev"
      ]
    }
  },
  "env": "TOXENV=py26",
  "install": [
    "pip install -r requirements/ci.pip"
  ],
  "script": [
    "tox",
    "if [ $COVERAGE_COVERAGE == 'yes' ]; then python igor.py combine_html; fi",
    "if [ $COVERAGE_COVERAGE == 'yes' ]; then pip install codecov; fi",
    "if [ $COVERAGE_COVERAGE == 'yes' ]; then codecov; fi"
  ],
  "group": "stable",
  "dist": "precise",
  "os": "linux"
}

and each travis jobs only runs py26. However, the .travis.yml from the sources has

env:
  - TOXENV=py26
  - TOXENV=py27
  - TOXENV=py33
  - TOXENV=py34
  - TOXENV=py35
  - TOXENV=pypy
  - TOXENV=py27 COVERAGE_COVERAGE=yes

and all environments should be considered.

Comments (1)

  1. Log in to comment