coverage and setuptools

Issue #7 resolved
Former user created an issue

Im running python 2.4 (CentOS 5.x build) with setuptools 0.6c9

when im trying to install coverage with:

{{{

!sh

easy_install coverage
}}}

i got:

{{{
Searching for coverage
Reading http://pypi.python.org/simple/coverage/
Reading http://nedbatchelder.com/code/modules/coverage.html
Reading http://nedbatchelder.com/code/coverage
Best match: coverage 3.0
Downloading http://pypi.python.org/packages/source/c/coverage/coverage-3.0.tar.gz#md5=aba99cde68916bd3c8c41c8bb874f68b
Processing coverage-3.0.tar.gz
error: Not a recognized archive type: /tmp/easy_install-7C2dtz/coverage-3.0.tar.gz
}}}

i also got an error when im trying to install coverage with a setup.py

{{{

!python

setup(
...
tests_require = ['coverage==2.85'],
)
}}}

{{{

!sh

./setup.py test
}}}

{{{
...
Searching for coverage==2.85
Reading http://cheeseshop.python.org/pypi/coverage/
Reading http://nedbatchelder.com/code/coverage
Reading http://cheeseshop.python.org/pypi/coverage/3.0
No local packages or download links found for coverage==2.85
error: Could not find suitable distribution for Requirement.parse('coverage==2.85')
}}}

Comments (5)

  1. Philip Jenvey

    The problem is the gid of the files contained in the tarball contain some kind of non-ascii characters which Python 2.4 tarfile's can't handle but >= 2.5 can. Ned needs to rebuild and upload the tarball without this funky gid, and maybe the eggs too for good measure

    $ tar -tzvf coverage-3.0.1.tar.gz 
    drwx------ batcheln/???????? 0 2009-07-06 19:26:21 coverage-3.0.1/
    -rwx------ batcheln/???????? 8397 2009-07-06 17:48:49 coverage-3.0.1/CHANGES.txt
    drwx------ batcheln/????????    0 2009-07-06 19:26:21 coverage-3.0.1/coverage/
    <etc>
    
  2. Log in to comment