Issue #7 resolved

coverage and setuptools

Pablo Castellazzi
created an issue

Im running python 2.4 (CentOS 5.x build) with setuptools 0.6c9

when im trying to install coverage with:



easy_install coverage }}}

i got:

{{{ Searching for coverage Reading Reading Reading Best match: coverage 3.0 Downloading Processing coverage-3.0.tar.gz error: Not a recognized archive type: /tmp/easy_install-7C2dtz/coverage-3.0.tar.gz }}}

i also got an error when im trying to install coverage with a



setup( ... tests_require = ['coverage==2.85'], ) }}}



./ test }}}

{{{ ... Searching for coverage==2.85 Reading Reading Reading No local packages or download links found for coverage==2.85 error: Could not find suitable distribution for Requirement.parse('coverage==2.85') }}}

Comments (5)

  1. Philip Jenvey

    The problem is the gid of the files contained in the tarball contain some kind of non-ascii characters which Python 2.4 tarfile's can't handle but >= 2.5 can. Ned needs to rebuild and upload the tarball without this funky gid, and maybe the eggs too for good measure

    $ tar -tzvf coverage-3.0.1.tar.gz 
    drwx------ batcheln/???????? 0 2009-07-06 19:26:21 coverage-3.0.1/
    -rwx------ batcheln/???????? 8397 2009-07-06 17:48:49 coverage-3.0.1/CHANGES.txt
    drwx------ batcheln/????????    0 2009-07-06 19:26:21 coverage-3.0.1/coverage/
  2. Log in to comment