3.4b1 breaks on Python 2.4

Issue #86 resolved
Alex Stewart created an issue

The docs say that it supports 2.3 onwards, but if I try to install 3.4b1 on Python 2.4, I get the following:

{{{ $ sudo easy_install-2.4 coverage Searching for coverage Reading http://pypi.python.org/simple/coverage/ Reading http://nedbatchelder.com/code/modules/coverage.html Reading http://nedbatchelder.com/code/coverage Reading http://nedbatchelder.com/code/coverage/3.4b1 Best match: coverage 3.4b1 Downloading http://pypi.python.org/packages/source/c/coverage/coverage-3.4b1.tar.gz#md5=f8e1c5c5522ac91a42e560f24abd0666 Processing coverage-3.4b1.tar.gz Running coverage-3.4b1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-2dzNxZ/coverage-3.4b1/egg-dist-tmp-84R4xq no previously-included directories found matching 'test' File "build/bdist.linux-x86_64/egg/coverage/main.py", line 1 from . import cmdline ^ SyntaxError: invalid syntax File "/usr/lib/python2.4/site-packages/coverage-3.4b1-py2.4-linux-x86_64.egg/coverage/main.py", line 1 from . import cmdline ^ SyntaxError: invalid syntax Adding coverage 3.4b1 to easy-install.pth file Installing coverage script to /usr/bin

Installed /usr/lib/python2.4/site-packages/coverage-3.4b1-py2.4-linux-x86_64.egg Processing dependencies for coverage Finished processing dependencies for coverage


The "from . import" syntax isn't supported prior to 2.5, AFAIK..

Comments (1)

  1. Log in to comment