Source

argh / docs / index.rst

.. include:: ../README

Dependencies
------------

The `argh` library is supported (and tested unless otherwise specified) on
the following versions of Python:

* 2.6 (`argparse` library is required)
* 2.7 (including PyPy 1.8)
* 3.1 (`argparse` library is required; **not** tested)
* 3.2
* 3.3

.. versionchanged:: 0.15
   Added support for Python 3.x, dropped support for Python ≤ 2.5.

.. versionchanged:: 0.18
   Improved support for Python 3.2, added support for Python 3.3.

Why this one?
-------------

See :doc:`similar`.

Details
-------

.. toctree::
   :maxdepth: 2

   tutorial
   reference
   similar
   projects

Indices and tables
==================

* :ref:`genindex`
* :ref:`modindex`
* :ref:`search`