Commits

Andy Mikhailenko  committed 7b394e1

Bump version.

  • Participants
  • Parent commits 6df85b3
  • Tags 0.18.0

Comments (0)

Files changed (4)

File archlinux-python/PKGBUILD

 # Maintainer: Andrey Mikhaylenko <neithere at gmail dot com>
 # Contributor: Fabien Devaux <fdev31 at gmail dot com>
 pkgname=python-argh
-pkgver=0.17.2
+pkgver=0.18.0
 pkgrel=1
 pkgdesc="A simple argparse wrapper"
 arch=(any)
 options=(!emptydirs)
 install=
 source=(http://pypi.python.org/packages/source/a/argh/argh-${pkgver}.tar.gz)
-md5sums=('c34d8116dcab4e529868a8688edc4c40')
+md5sums=('3f24eb284cbd636262425c06f58a1633')
 
 build() {
    cd "${srcdir}/argh-${pkgver}"

File archlinux-python2/PKGBUILD

 # Maintainer: Andrey Mikhaylenko <neithere at gmail dot com>
 # Contributor: Fabien Devaux <fdev31 at gmail dot com>
 pkgname=python2-argh
-pkgver=0.17.2
+pkgver=0.18.0
 pkgrel=1
 pkgdesc="A simple argparse wrapper"
 arch=(any)
 options=(!emptydirs)
 install=
 source=(http://pypi.python.org/packages/source/a/argh/argh-${pkgver}.tar.gz)
-md5sums=('c34d8116dcab4e529868a8688edc4c40')
+md5sums=('3f24eb284cbd636262425c06f58a1633')
 
 build() {
    cd "${srcdir}/argh-${pkgver}"

File argh/__init__.py

 from .helpers import *
 from .decorators import *
 
-__version__ = '0.17.2'
+__version__ = '0.18.0'

File docs/index.rst

 * 2.7 (including PyPy 1.8)
 * 3.1 (`argparse` library is required; **not** tested)
 * 3.2
+* 3.3
+
+.. versionchanged:: 0.18
+   Improved support for Python 3.2, added support for Python 3.3.
 
 .. versionchanged:: 0.15
    Added support for Python 3.x, dropped support for Python ≤ 2.5.