Commits

Andy Mikhailenko  committed b900869

Fix #41: argparse dependency must not be required for Python ≥ 2.7

  • Participants
  • Parent commits 44a7add

Comments (0)

Files changed (2)

File argh/__init__.py

 from .helpers import *
 
 
-__version__ = '0.23.0'
+__version__ = '0.23.1'
         sys.exit(errno)
 
 
+if sys.version_info < (2,7):
+    install_requires = ['argparse >= 1.1']
+else:
+    install_requires = []
+
+
 setup(
     # overview
     name             = 'argh',
     version  = __version__,
     packages = ['argh'],
     provides = ['argh'],
-    requires = ['python(>=2.6)', 'argparse(>=1.1)'],
-    install_requires = ['argparse>=1.1'],    # for Python 2.6 (no bundled argparse; setuptools is likely to exist)
+    install_requires = install_requires,
 
     # testing
     tests_require=['pytest'],