paver ImportError problems

Issue #35 resolved
Travis Shirk
repo owner created an issue

Via rick.carter@gmail.com

On Mac OS X 10.4.8, python 2.7.2, there's an installation failure (seen below). I fixed it by unzipping the paver stuff and editing paver/tasks.py -- removed the "import version" line and just hardcoded VERSION="0.7.2" and it then built fine. I'm kinda a python newb so I don't know if there is a setting wrong on my Mac or anything, but here was the error:

                meatwad:~ root# pip install eyeD3
                Downloading/unpacking eyeD3
                  Downloading eyeD3-0.7.2.tgz (184Kb): 184Kb downloaded
                  Running setup.py egg_info for package eyeD3
                    Traceback (most recent call last):
                      File "<string>", line 14, in <module>
                      File "/var/root/.pip/build/eyeD3/setup.py", line 8, in <module>
                        import paver.tasks
                      File "paver-minilib.zip/paver/tasks.py", line 16, in <module>
                    ImportError: No module named version
                    Complete output from command python setup.py egg_info:
                    Traceback (most recent call last):

                  File "<string>", line 14, in <module>

                  File "/var/root/.pip/build/eyeD3/setup.py", line 8, in <module>

                    import paver.tasks

                  File "paver-minilib.zip/paver/tasks.py", line 16, in <module>

                ImportError: No module named version

                ----------------------------------------
                Command python setup.py egg_info failed with error code 1
                Storing complete log in /var/root/Library/Logs/pip.log

Comments (2)

  1. Log in to comment