The Python-LLFUSE Module

Warning - no longer maintained

Python-LLFUSE is no longer actively maintained. Unless you are stuck with Python 2.x or libfuse 2.x, we recommended to use the pyfuse3 module instead.

Python-LLFUSE is a set of Python bindings for the low level FUSE API. It requires at least FUSE 2.8.0 and supports both Python 2.x and 3.x. Like FUSE itself, Python-LLFUSE is developed for Linux systems. However, we try to maintain compatibility with OS-X, FreeBSD and NetBSD as well (but due to lack of pre-release testers we can't guarantee that every Python-LLFUSE release will run on these platforms - please report any bugs and we will try to fix them).

Python-LLFUSE releases can be downloaded from PyPi. The documentation can be read online and is also included in the doc/html directory of the Python-LLFUSE tarball.

Getting Help

Please report any bugs on the issue tracker. For discussion and questions, please use the general FUSE mailing list. A searchable mailing list archive is kindly provided by Gmane.

Development Status

The Python-LLFUSE API is not yet stable and may change from one release to the other. Starting with version 0.42, Python-LLFUSE uses semantic versioning. This means changes in the API will be reflected in an increase of the major version number, i.e. the next backwards-incompatible version will be 1.0. Projects designed for e.g. version 0.42.1 of Python-LLFUSE are thus recommended to declare a dependency on llfuse >= 0.42.1, < 1.0.


The Python-LLFUSE source code is available both on GitHub and BitBucket.

Professional Support

Professional support is offered via Rath Consulting.