TH14 on Win7 doesn't translate at all into English

Issue #25 resolved
Former user created an issue

After running thcrap_configure(which seemed to work fine) for only en, I tried starting TH14 using the shortcut and nothing at all was translated. I checked the patch files and all of it was there(for up to stage 3 of course), including the translated image files, but none of it appeared ingame. I tried TH13 afterward and it seemed to work just fine, so I'm at a complete loss.

Comments (8)

  1. UnRaVeLinG

    So I've got pretty much the same problem, except for me both TH13 and TH14 won't get translated, while for example TH07 translates perfectly well. (Edit: Mistake on my part here, TH13 translation works, see below. Only TH14 doesn't.) Previously the demo too translated just fine, only after deleting the demo folder and thcrap folder, installing TH14 full version and redownloading+reapplying thcrap things refuse to work. I didn't change anything in how I set everything up and the files (e.g. image translations) are there, but the translation isn't applied when I start TH13 or TH14 via the corresponding shortcuts for english language.

    I already tried reinstalling TH14 and reapplying thcrap but the issue remains the same. As I fail to figure out how to attach the log.txt (maybe only OP can attach something?) only some minor information which may or may not be needed: - Operating System is Windows 7 x64 - my Touhou Folder is located on D: instead of C: - I did turn my firewall off while testing, but even when on it didn't block anything - I also tried removing unneccessary symbols (~) and shortening folder paths, as well as copying TH14 and thcrap directly onto C: root folder before applying the patch again in that location

    I would really appreciate help on this matter as I was looking forward to the game all day :) Many Thanks in advance!

    €: I forgot to mention that my PC is set to japanese locale, but it has been since forever and the demos translation didn't seem to mind.

  2. BladeySword

    Hi, OP here. It may not be anything important, but I'd like to point out a couple similarities between myself and the previous poster. My Touhou folder is also located in another drive besides C:(in my case G:), and I'm also running Windows 7 x64

  3. UnRaVeLinG

    First I would like to clear up a mistake on my part: TH13 does get properly translated. It seems I confused the shortcuts, sorry! (Previous post edited.)

    I think we can assume the secondary drive isn't the issue here. I just completely redownloaded TH14, extracted it to C:\Touhou\, put thcrap there as well, applied it, and the issue remains the same. Firewall off, no other applications running, rebooted beforehand.

    Then I did the same for TH07, TH10 and TH13, all 3 get properly translated, so the problem only occurs with TH14.

  4. UnRaVeLinG

    I hope it's alright to post two times in a row, so BladeySword kann see I responded again.

    I don't know whether anything that I did fixed the issue or the patch was fixed, but here is what I did and what I noticed: I completely uninstalled TH14 using the uninstall.exe that was in the TH14 folder in D:\Touhou\, removing it from Windows Control Panel and deleted the folder afterwards. (If the game is just copied instead of installed there should be no uninstall.exe and deleting the folder should be the same as uninstalling the game.) Then I deleted the th14 folder in C:\Users\<Username>\AppData\Roaming\ShanghaiAlice\, as well as thcrap folder and rebooted the PC. (After switching the firewall off) I then extracted TH14 back to D:\Touhou\ instead of installing it, extracted thcrap as well and configured it. After starting the game I noticed, that the Manual and Character selection were now properly translated, while the difficulty selection wasn't (even though the neccessary images were right there in thcrap\thpatch\lang_en\title). Maybe this is intended, I don't know and it doesn't really bother. I then started the game to find the ingame dialogue to be translated as well only to have the game crash like described in the newest issue (#26). (First time it crashed at the beginning of Wakasagihimes dialogue, second time at the second Wakasagihime dialogue, third time right at the beginning of stage 2 and fourth time again at Wakasagihimes first dialogue. I tested around a bit more and it really seems to crash randomly.)

  5. nmlgc repo owner

    You didn't have to do all this uninstalling and reinstalling. thcrap's support for the full version of th14 was completed 11 hours ago, and after the next update-restart cycle, you would have seen it... which is also why you're seeing it now.

    As for the difficulty selection, it's not translated yet because the file you're seeing is rank00tr.png for the trial version (it misses the "Extra Stage" selector).

  6. UnRaVeLinG

    Thank you for your response and explaining! I didn't know the patch was completed 11 hours ago and so I just tried anything that came to mind before even checking back here. :) (The thing with the difficulty selection is something I really could have understood on my own though..)

    Thank you for your hard work and good luck fixing the crash-issue!

  7. BladeySword

    Then I apologize for my impatience here, I had assumed it was already supported when I tried it. It works now, obviously, so thanks for the response and sorry for essentially wasting your time.

  8. Log in to comment