Can't find DLL files

Issue #88 new
Tagglink422 .
created an issue

Heyo! This problem is similar to the "Patcher not running" thread posted previously on this board. I try to run any shortcut created by the thcrap patcher, or just run thcrap_configure.exe , but all it does is play the loading cursor animation until I close the explorer window. Nothing happens. However, it does create a process that can't be killed which looks like this:

ss1.png

This problem occured after I exited a thcrap-translated version of Touhou 15 using the game-window's X button instead of going to the game title menu and electing "Quit game". To clarify, before this incident all of my thcrap-created shortcuts (around 10) for different Touhou games worked without problem. Now, they are all broken. I have tried to download a new build from https://www.thpatch.net/wiki/Touhou_Patch_Center:Download without success.

In the thread with a similar problem, you recommended to download Dependency Walker, which I did, and it produced the following output for thcrap_configure.exe

ss2.png

The output for thcrap_loader.exe is the same.

I googled one of the DLL names and it took me to this stackoverflow thread , which recommends to update Visual C++ Redistributable packages. I have tried to repair my current installations of Visual C++ Redistributable (2015, 2013, 2012, 2010, 2008), but this didn't fix the problem.

Comments (3)

  1. Tagglink422 . reporter

    Oh, uhm, well, this is awkward, but it seems like all the shortcuts work just fine now. I have no idea what I did. But they work now. However I still can't start thcrap_configure.exe

  2. Log in to comment