Ubuntu package for 0.10.x?

Create issue
Issue #60 new
Former user created an issue

After a while of tinkering with arbtt (this has some true potential to replace everything time tracking wise for me, I'm really excited about this tool), I noticed that the version I have isn't the latest one.

Ubuntu 18.04 has arbtt 0.9.0.13 but the documentation states the latest version being 0.10.2 Is there a maintainer for the Ubuntu package, and is there any update coming to 18.04?

Comments (2)

  1. nomeata repo owner

    I believe Ubuntu copies these packages from Debian, and Debian unstable has 0.10.1. I don’t think 18.04 is going to see an update, and newer versions of arbtt will trickle into newer versions of Ubuntu eventually.

    But arbtt doesn’t change a lot, if you look at http://arbtt.nomeata.de/doc/users_guide/release-notes.html you’ll see that you are not missing much.

    If you really want you can also install it from source via cabal: http://arbtt.nomeata.de/doc/users_guide/index.html#idp46432013336864

  2. Mat Rich

    I tried this out (Ubuntu 18.04) and got this as a result:

    \$ sudo cabal install arbtt
    Resolving dependencies...
    Downloading data-default-class-0.1.2.0...
    Downloading deepseq-1.4.4.0...
    Downloading ghc-boot-th-8.6.5...
    Configuring data-default-class-0.1.2.0...
    Downloading integer-logarithms-1.0.3...
    Configuring deepseq-1.4.4.0...
    Downloading mtl-2.2.2...
    Configuring integer-logarithms-1.0.3...
    Building data-default-class-0.1.2.0...
    Building deepseq-1.4.4.0...
    Building integer-logarithms-1.0.3...
    Downloading old-locale-1.0.0.7...
    Configuring mtl-2.2.2...
    Downloading primitive-0.6.4.0...
    Configuring old-locale-1.0.0.7...
    Installed data-default-class-0.1.2.0
    Downloading split-0.2.3.3...
    Building mtl-2.2.2...
    Building old-locale-1.0.0.7...
    Downloading stm-2.5.0.0...
    Downloading strict-0.3.2...
    Installed deepseq-1.4.4.0
    Configuring ghc-boot-th-8.6.5...
    Configuring split-0.2.3.3...
    Installed integer-logarithms-1.0.3
    Building ghc-boot-th-8.6.5...
    Downloading terminal-size-0.3.2.1...
    Downloading transformers-compat-0.6.5...
    Building split-0.2.3.3...
    Downloading unliftio-core-0.1.2.0...
    Configuring primitive-0.6.4.0...
    Installed old-locale-1.0.0.7
    Downloading bytestring-0.10.8.2...
    Building primitive-0.6.4.0...
    Downloading containers-0.6.1.1...
    Downloading dlist-0.8.0.6...
    Installed split-0.2.3.3
    Configuring stm-2.5.0.0...
    Downloading pretty-1.1.3.6...
    Configuring strict-0.3.2...
    Installed mtl-2.2.2
    Building stm-2.5.0.0...
    Downloading time-1.8.0.4...
    Building strict-0.3.2...
    Downloading data-default-instances-old-locale-0.0.1...
    Configuring terminal-size-0.3.2.1...
    Installed ghc-boot-th-8.6.5
    Building terminal-size-0.3.2.1...
    Configuring unliftio-core-0.1.2.0...
    Installed strict-0.3.2
    Configuring transformers-compat-0.6.5...
    Installed stm-2.5.0.0
    Building unliftio-core-0.1.2.0...
    Building transformers-compat-0.6.5...
    Configuring bytestring-0.10.8.2...
    Installed terminal-size-0.3.2.1
    Building bytestring-0.10.8.2...
    Installed unliftio-core-0.1.2.0
    Configuring dlist-0.8.0.6...
    Building dlist-0.8.0.6...
    Configuring pretty-1.1.3.6...
    Installed dlist-0.8.0.6
    Downloading data-default-instances-dlist-0.0.1...
    Building pretty-1.1.3.6...
    Configuring data-default-instances-old-locale-0.0.1...
    Installed transformers-compat-0.6.5
    Building data-default-instances-old-locale-0.0.1...
    Configuring containers-0.6.1.1...
    Installed data-default-instances-old-locale-0.0.1
    Building containers-0.6.1.1...
    Configuring time-1.8.0.4...
    Installed pretty-1.1.3.6
    Downloading template-haskell-2.14.0.0...
    Installed primitive-0.6.4.0
    Downloading vector-0.12.0.3...
    Configuring data-default-instances-dlist-0.0.1...
    Building data-default-instances-dlist-0.0.1...
    Installed data-default-instances-dlist-0.0.1
    Configuring vector-0.12.0.3...
    Building time-1.8.0.4...
    Building vector-0.12.0.3...
    Configuring template-haskell-2.14.0.0...
    Installed bytestring-0.10.8.2
    Downloading pcre-light-0.4.0.3...
    Downloading utf8-string-1.0.1.1...
    Building template-haskell-2.14.0.0...
    Installed time-1.8.0.4
    Downloading bytestring-progress-1.2...
    Downloading random-1.1...
    Configuring utf8-string-1.0.1.1...
    Downloading time-locale-compat-0.1.1.5...
    Building utf8-string-1.0.1.1...
    Downloading unix-2.7.2.2...
    Configuring pcre-light-0.4.0.3...
    Installed utf8-string-1.0.1.1
    Failed to install pcre-light-0.4.0.3
    Build log ( /home/user1/.cabal/logs/pcre-light-0.4.0.3.log ):
    cabal: Entering directory '/tmp/cabal-tmp-14570/pcre-light-0.4.0.3'
    Configuring pcre-light-0.4.0.3...
    cabal: Missing dependency on a foreign library:

    • Missing C library: pcre
      This problem can usually be solved by installing the system package that
      provides this library (you may need the "-dev" version). If the library is
      already installed but in a non-standard location then you can use the flags
      --extra-include-dirs= and --extra-lib-dirs= to specify where it is.
      cabal: Leaving directory '/tmp/cabal-tmp-14570/pcre-light-0.4.0.3'
      Configuring bytestring-progress-1.2...
      Building bytestring-progress-1.2...
      Configuring time-locale-compat-0.1.1.5...
      Installed bytestring-progress-1.2
      Building time-locale-compat-0.1.1.5...
      Configuring random-1.1...
      Installed time-locale-compat-0.1.1.5
      Building random-1.1...
      Configuring unix-2.7.2.2...
      Installed random-1.1
      Building unix-2.7.2.2...
      Installed containers-0.6.1.1
      Downloading binary-0.8.7.0...
      Downloading data-default-instances-containers-0.0.1...
      Configuring binary-0.8.7.0...
      Building binary-0.8.7.0...
      Configuring data-default-instances-containers-0.0.1...
      Installed template-haskell-2.14.0.0
      Downloading exceptions-0.10.2...
      Downloading tagged-0.8.6...
      Installed unix-2.7.2.2
      Building data-default-instances-containers-0.0.1...
      Configuring tagged-0.8.6...
      Downloading th-abstraction-0.2.11.0...
      Downloading base-compat-0.10.5...
      Building tagged-0.8.6...
      Downloading directory-1.3.3.2...
      Installed data-default-instances-containers-0.0.1
      Downloading data-default-0.7.1.1...
      Configuring th-abstraction-0.2.11.0...
      Building th-abstraction-0.2.11.0...
      Configuring exceptions-0.10.2...
      Installed tagged-0.8.6
      Building exceptions-0.10.2...
      Configuring base-compat-0.10.5...
      Installed exceptions-0.10.2
      Downloading resourcet-1.2.2...
      Installed th-abstraction-0.2.11.0
      Configuring directory-1.3.3.2...
      Building base-compat-0.10.5...
      Building directory-1.3.3.2...
      Configuring data-default-0.7.1.1...
      Installed base-compat-0.10.5
      Building data-default-0.7.1.1...
      Configuring resourcet-1.2.2...
      Installed data-default-0.7.1.1
      Downloading X11-1.9...
      Installed binary-0.8.7.0
      Downloading text-1.2.3.1...
      Configuring X11-1.9...
      Building resourcet-1.2.2...
      Failed to install X11-1.9
      Build log ( /home/user1/.cabal/logs/X11-1.9.log ):
      cabal: Entering directory '/tmp/cabal-tmp-14569/X11-1.9'
      Configuring X11-1.9...
      configure: WARNING: unrecognized options: --with-compiler
      checking for gcc... /usr/bin/gcc
      checking whether the C compiler works... yes
      checking for C compiler default output file name... a.out
      checking for suffix of executables...
      checking whether we are cross compiling... no
      checking for suffix of object files... o
      checking whether we are using the GNU C compiler... yes
      checking whether /usr/bin/gcc accepts -g... yes
      checking for /usr/bin/gcc option to accept ISO C89... none needed
      checking how to run the C preprocessor... /usr/bin/gcc -E
      checking for X... no
      configure: error: in /tmp/cabal-tmp-14569/X11-1.9': configure: error: X11 libraries not found, so X11 package cannot be built Seeconfig.log' for more details
      cabal: Leaving directory '/tmp/cabal-tmp-14569/X11-1.9'
      Configuring text-1.2.3.1...
      Installed directory-1.3.3.2
      Building text-1.2.3.1...
      Installed resourcet-1.2.2
      Installed vector-0.12.0.3
      Downloading vector-algorithms-0.8.0.1...
      Configuring vector-algorithms-0.8.0.1...
      Building vector-algorithms-0.8.0.1...
      Installed vector-algorithms-0.8.0.1
      Installed text-1.2.3.1
      Downloading hashable-1.3.0.0...
      Downloading parsec-3.1.13.0...
      Downloading terminal-progress-bar-0.4.0.1...
      Configuring hashable-1.3.0.0...
      Configuring parsec-3.1.13.0...
      Building hashable-1.3.0.0...
      Building parsec-3.1.13.0...
      Configuring terminal-progress-bar-0.4.0.1...
      Building terminal-progress-bar-0.4.0.1...
      Installed hashable-1.3.0.0
      Downloading scientific-0.3.6.2...
      Downloading unordered-containers-0.2.10.0...
      Downloading uuid-types-1.0.3...
      Configuring scientific-0.3.6.2...
      Configuring uuid-types-1.0.3...
      Building scientific-0.3.6.2...
      Building uuid-types-1.0.3...
      Configuring unordered-containers-0.2.10.0...
      Installed terminal-progress-bar-0.4.0.1
      Building unordered-containers-0.2.10.0...
      Installed uuid-types-1.0.3
      Installed parsec-3.1.13.0
      Installed scientific-0.3.6.2
      Downloading attoparsec-0.13.2.2...
      Configuring attoparsec-0.13.2.2...
      Building attoparsec-0.13.2.2...
      Installed unordered-containers-0.2.10.0
      Downloading mono-traversable-1.0.11.0...
      Configuring mono-traversable-1.0.11.0...
      Building mono-traversable-1.0.11.0...
      Installed attoparsec-0.13.2.2
      Downloading aeson-1.4.1.0...
      Configuring aeson-1.4.1.0...
      Building aeson-1.4.1.0...
      Failed to install aeson-1.4.1.0
      Build log ( /home/user1/.cabal/logs/aeson-1.4.1.0.log ):
      cabal: Entering directory '/tmp/cabal-tmp-14566/aeson-1.4.1.0'
      Configuring aeson-1.4.1.0...
      Building aeson-1.4.1.0...
      Preprocessing library aeson-1.4.1.0...
      [ 1 of 24] Compiling Data.Attoparsec.Time.Internal ( attoparsec-iso8601/Data/Attoparsec/Time/Internal.hs, dist/build/Data/Attoparsec/Time/Internal.o )

    attoparsec-iso8601/Data/Attoparsec/Time/Internal.hs:24:1: warning: [-Wunused-imports]
    The import of ‘Unsafe.Coerce’ is redundant
    except perhaps to import instances from ‘Unsafe.Coerce’
    To import instances alone, use: import Unsafe.Coerce()
    [ 2 of 24] Compiling Data.Attoparsec.Time ( attoparsec-iso8601/Data/Attoparsec/Time.hs, dist/build/Data/Attoparsec/Time.o )
    [ 3 of 24] Compiling Data.Aeson.Types.Internal ( Data/Aeson/Types/Internal.hs, dist/build/Data/Aeson/Types/Internal.o )

    Data/Aeson/Types/Internal.hs:398:17: error:
    • Can't find interface-file declaration for type constructor or class Language.Haskell.TH.Lib.ExpQ
    Probable cause: bug in .hi-boot file, or inconsistent .hi file
    Use -ddump-if-trace to get an idea of which file caused the error
    • In the expression: [| Null |]
    In an equation for ‘lift’: lift Null = [| Null |]
    In the instance declaration for ‘TH.Lift Value’
    cabal: Leaving directory '/tmp/cabal-tmp-14566/aeson-1.4.1.0'
    Installed mono-traversable-1.0.11.0
    Downloading conduit-1.3.1.1...
    Configuring conduit-1.3.1.1...
    Building conduit-1.3.1.1...
    Installed conduit-1.3.1.1
    cabal: Error: some packages failed to install:
    X11-1.9 failed during the configure step. The exception was:
    ExitFailure 1
    aeson-1.4.1.0 failed during the building phase. The exception was:
    ExitFailure 1
    arbtt-0.10.2 depends on pcre-light-0.4.0.3 which failed to install.
    pcre-light-0.4.0.3 failed during the configure step. The exception was:
    ExitFailure 1

    Installing pcre-light was easy enough, but then there are issues of finding the right dependencies for X11-1.9 and aeson. I’m sorry to say but “just running “ $ cabal install arbtt as the documentation suggests is at least in my case a bit away from the intended result.

    I’ll just stick to the older version of arbtt that can be installed by apt. Unfortunately, it also means that I won’t be able to use some of the features that are included in the current documentation such as $now and condition.

  3. Log in to comment