Custom field Usage status inaccurate

Issue #2 closed
Nand Govind Modani created an issue

I've installed trial version of the plugin to see if we want to buy it. It seems like the Usage shown by the Plugin, even for non-calculated custom fields is not accurate. I've attached evidence that 2 custom fields (there are many but I'm just giving 2 of them), which are not calculated fields in our system, are marked as NOT USED by plugin but there are issues that have value assigned to those fields. We are using JIRA (server) v6.3.15 and Custom Fields Usage for JIRA Plugin v1.7.3

Comments (6)

  1. Nand Govind Modani reporter

    PFB DB details: Database type mssql Database version 10.50.6000 Database driver jTDS Type 4 JDBC Driver for MS SQL Server and Sybase 1.3.1

  2. Alexey Dorofeyev

    Ok, as we can't reproduce this bug in our test environment i want to ask you to do following: 1) choose any field mistakenly marked as "unused" (for example "$ Actual revenue (+12 month)") and get it's ID. Easiest way is to look at delete field url, it looks like https://YOUR_JIRA_BASE_URL/secure/admin/DeleteCustomField!default.jspa?id=FIELD_ID

    2) Perform following request on you Jira DB:

    SELECT DISTINCT CUSTOMFIELD FROM customfieldvalue
    

    and search for field ID in the result. It must be there, otherwise problem is in DB level and we will dig this way.

    BTW, yesterday we released new version 1.7.4 which contains some refactoring and code improvements, try it.

  3. Nand Govind Modani reporter

    Yes I tried looking up the custom field ID in DB and in JIRA. They are matching. SO doesn't seem like any issue at DB level. As stated, the custom field usage is still showing NOT USED which is inaccurate. I'll try the upgrade as well this week.

  4. Log in to comment