Commits

Takeshi NISHIDA  committed d693d17

some minor changes

  • Participants
  • Parent commits 9727c89

Comments (0)

Files changed (3)

         <your runtime directory>/doc/acp.txt
         ...
 <
-もしランタイムディレクトリが他のプラグインとごた混ぜになるのが嫌なら、ファイル
-を新規ディレクトリに配置し、そのディレクトリのパスを 'runtimepath' に追加して
-ください。アンインストールも楽になります。
+もしランタイムディレクトリが多数のプラグインでごちゃごちゃになるのが嫌なら、各
+プラグインを個別のディレクトリに配置し、そのディレクトリのパスを 'runtimepath'
+に追加してください。アンインストールも楽になります。
 
-その後 FuzzyFinder のヘルプを有効にするためにタグファイルを更新してください。
-詳しくは|add-local-help|を参照してください。
+その後、ヘルプを有効にするためにタグファイルを更新してください。詳しくは
+|add-local-help|を参照してください。
+
+必要なもの: ~
+
+- L9 library ( http://bitbucket.org/ns9tks/vim-l9/ )
 
 
 ==============================================================================
         <your runtime directory>/doc/acp.txt
         ...
 <
-If you disgust to jumble up this plugin and other plugins in your runtime
-directory, put the files into new directory and just add the directory path to
-'runtimepath'. It's easy to uninstall the plugin.
+If you are disgusted to make your runtime directory confused with a lot of
+plugins, put each of the plugins into a directory individually and just add
+the directory path to 'runtimepath'. It's easy to uninstall the plugin.
 
-And then update your help tags files to enable fuzzyfinder help. See
+Then update your help tags files to enable the help for this plugin. See
 |add-local-help| for details.
 
+Requirements: ~
+
+- L9 library ( http://bitbucket.org/ns9tks/vim-l9/ )
+
 
 ==============================================================================
 USAGE                                                              *acp-usage*

File plugin/acp.vim

 "=============================================================================
 " LOAD GUARD {{{1
 
-let s:VERSION_VIM = 702
-let s:VERSION_L9 = 00.0100
+let s:REQUIRED_VERSION_VIM = 702
+let s:REQUIRED_VERSION_L9 = 1.0
 if exists('g:loaded_acp')
   finish
-elseif v:version < s:VERSION_VIM
-  echoerr 'AutoComplPop requires Vim version ' . s:VERSION_VIM
+elseif v:version < s:REQUIRED_VERSION_VIM
+  echoerr 'AutoComplPop requires Vim version ' . string(s:REQUIRED_VERSION_VIM)
   finish
-elseif !exists('*l9#isCompatible') || !l9#isCompatible(s:VERSION_L9)
-  echoerr 'AutoComplPop requires l9 library version ' . s:VERSION_L9
+elseif !exists('*l9#isCompatible') || !l9#isCompatible(s:REQUIRED_VERSION_L9)
+  echoerr 'AutoComplPop requires L9 library version ' . string(s:REQUIRED_VERSION_L9)
   finish
 endif
 let g:loaded_acp = 1