Issue #1 resolved

Support for snipMate

created an issue

Hi, well actually this isn't an issue but a request for a feature. I've just started to use your plugin and it's incredible!, although it could be better, jeje (I mean. It could be great if it had support for other languages, omni-completion supports lots of them). I use to program in C, not as a professional but I use to, and I've found another excellent plugin that help me to type less code and faster. Snipmate allows to insert lots of often-typed text with a little trigger.

So I thought that it'd be great if autocomplpop could auto-complete that triggers who will expand in a more specific text :).

I don't have any experience with vim scripting language, but I browsed the code and I've tried to add this feature by myself without success. Well actually it can auto-complete but I get many security warnings (E523). So I hope you can give a hand.

Also if you could explain me more in detail the pattern options I will be happy to help with the rest of omni-completion supported languages.

I attach the patch. I used the latest stable version (2.6). Thanks in advance, and excuse my English, I've just started to learn it.

Comments (3)

  1. Anonymous

    OMFG!!!, I love you, this is just awesome!, although the uppercase thing is some kind inconvenient I'm sure this will be delete it in future version, wowow, I'm really excited, thx man, keep up the good work : )

  2. Log in to comment