Read the documentation.

Installation requirements

Non-python dependencies

  • Mirnylib provides a HDF5 dictionary type based on the Python h5py package. For the h5py package to install properly, you need to have the shared library and development headers for HDF5 1.8.4 or newer installed (libhdf5-dev or similar). See the h5py docs for more information.

  • You will also need the bowtie2 mapping software which can be downloaded manually or installed via the download_bowtie.sh script in the hiclib folder.

Python dependencies


Getting the basic Scientific Python stack (numpy/scipy/matplotlib) can be trickier on some platforms than others. For more details, see the instructions on scipy.org. You should already have these dependencies installed and running correctly before attempting to install this package.

  • numpy (1.6+)
  • scipy
  • matplotlib

Installed by setuptools if missing:


  • Sphinx (to generate documentation)