Source

openbiblio / INSTALL_UBUNTU.txt

The default branch has multiple heads

Full commit
Ubuntu minimal will need the following packages to install
according to the instructions:

	apt-get install python-virtualenv
	apt-get install g++
	apt-get install python-dev
	apt-get install libiodbc2-dev
	ln -s /usr/lib/libiodbc.so /usr/lib/libodbc.so

This last line is necessary because Ubuntu and Debian are 
schizophrenic with respect to ODBC implementations

To install the packaged version if Virtuoso do:

	apt-get install virtuoso-opensource
	apt-get install libvirtodbc0

For installing Virtuoso from source you also need:

	apt-get install libssl-dev
	apt-get install gawk

and do *not* do:

	apt-get install libvirtodbc0

and in your odbc.ini you will need to put

	Driver = /usr/local/virtuoso-opensource/lib/virtodbc.so

assuming you told the virtuoso configure to put things in
the default places