Issue #29 wontfix

Python 2.4 support broken

glenfant
created an issue

Could you please tell in the README or changelog what Python versions are supported ?

In particular, for Plone 3 I need a Python 2.4 support, what is the best version of pyquery in that case ?

Comments (4)

  1. Gael Pasgrimaud

    Hi Gillux!

    Have you solved your issue ? I'd like to add this to pypi's metadata

    If I remember well pyquery < 1.0 is compatible with py2.4 but I no longer have it on my system...

  2. glenfant reporter

    Hi Gawel,

    pyquery 0.7 has some Python 2.5 new features (relative imports). I have no Python 2.5 in my macbouc.

    It seems that with Python 2.4 you can use pyquery <= 0.6.1 (insalls without screamig, some basic interactive tests are OK) but I could not run the unit tests since they require too much intrusive environment : using webob (why ?), requires then a .../site-packages/docs directory (!!!)

    IMO, the Python version should be checked directly in the setup.py of each egg such we don't need to open such issue ;)

    Cheers and see you on 23rd (?)

  3. Log in to comment