Commits

Anonymous committed 929b1d4 Draft

0.8dev: Removed //Trac// and //setuptools// from package installation requirements.

//Trac// should not be specified as an installation requirement. It causes problems when running `pip install -U`. See also discussion in th:#9800.

Comments (0)

Files changed (4)

bloodhound_dashboard/setup.py

     url = "https://bloodhound.apache.org/",
     requires = ['trac'],
     tests_require = ['dutest>=0.2.4', 'TracXMLRPC'],
-    install_requires = [
-        'setuptools>=0.6b1',
-        'Trac>=0.11',
-    ],
     package_dir = dict([p, i[0]] for p, i in PKG_INFO.iteritems()),
     packages = PKG_INFO.keys(),
     package_data = dict([p, i[1]] for p, i in PKG_INFO.iteritems()),

bloodhound_relations/setup.py

     license = "Apache License v2",
     url = "https://bloodhound.apache.org/",
     requires = ['trac'],
-    install_requires = [
-        'setuptools>=0.6b1',
-        'Trac>=0.11',
-    ],
     package_dir = dict([p, i[0]] for p, i in PKG_INFO.iteritems()),
     packages = PKG_INFO.keys(),
     package_data = dict([p, i[1]] for p, i in PKG_INFO.iteritems()),

bloodhound_search/setup.py

     license = "Apache License v2",
     url = "https://bloodhound.apache.org/",
     requires = ['trac'],
-    install_requires = [
-        'setuptools>=0.6b1',
-        'Trac>=0.11',
-        'whoosh>=2.5.1',
-    ],
+    install_requires = ['whoosh>=2.5.1'],
     package_dir = dict([p, i[0]] for p, i in PKG_INFO.iteritems()),
     packages = PKG_INFO.keys(),
     package_data = dict([p, i[1]] for p, i in PKG_INFO.iteritems()),

bloodhound_theme/setup.py

   classifiers = [
       'Framework :: Trac',
     ],
-  install_requires = ['BloodhoundDashboardPlugin', 'TracThemeEngine', 'Trac'],
+  install_requires = ['BloodhoundDashboardPlugin', 'TracThemeEngine'],
   tests_require = ['unittest2'] if sys.version_info < (2, 7) else [],
   entry_points = {
       'trac.plugins': [