Issue #53 resolved

can't finish 'make update_bindings'

Yannik-kenzeler
created an issue

Hello, i've installed ompl 0.13.0 on 2 laptops with ubuntu 12.04 in a virtual box. It both worked out well. But now i'm trying to install ompl.app on a dual booted pc, also with ubuntu 12.04.

I followed the same steps as i did before, but i can't compile cmake or the update bindings. When i type 'make update_bindings' in the build directory, this is what i get:

[ 11%] Preparing C++ header file for Python binding generation for module util
[ 11%] Built target util.h
[ 11%] Creating C++ code for Python module util (see pyplusplus_util.log)
-- checking for module 'ccd=1.4'
--   package 'ccd=1.4' not found
-- checking for module 'fcl>=0.2.7'
--   package 'fcl>=0.2.7' not found
-- CCD library not found.  Will download and compile.
-- FCL library not found.  Will download and compile.
-- checking for module 'assimp'
--   found assimp, version 2.0
-- Code for module control not found; type "make update_bindings"
-- Code for module geometric not found; type "make update_bindings"
-- Code for module tools not found; type "make update_bindings"
-- Code for module app not found; type "make update_bindings"
-- Configuring done
-- Generating done
-- Build files have been written to: /home/binpicking/omplapp/build/Release
[ 11%] Built target update_util_bindings
[ 11%] Preparing C++ header file for Python binding generation for module base
[ 11%] Built target base.h
[ 11%] Creating C++ code for Python module base (see pyplusplus_base.log)
-- checking for module 'ccd=1.4'
--   package 'ccd=1.4' not found
-- checking for module 'fcl>=0.2.7'
--   package 'fcl>=0.2.7' not found
-- CCD library not found.  Will download and compile.
-- FCL library not found.  Will download and compile.
-- checking for module 'assimp'
--   found assimp, version 2.0
-- Code for module control not found; type "make update_bindings"
-- Code for module geometric not found; type "make update_bindings"
-- Code for module tools not found; type "make update_bindings"
-- Code for module app not found; type "make update_bindings"
-- Configuring done
-- Generating done
-- Build files have been written to: /home/binpicking/omplapp/build/Release
[ 11%] Built target update_base_bindings
[ 22%] Preparing C++ header file for Python binding generation for module geometric
[ 22%] Built target geometric.h
[ 33%] Creating C++ code for Python module geometric (see pyplusplus_geometric.log)
make[3]: *** [ompl/py-bindings/CMakeFiles/update_geometric_bindings] Error 137
make[2]: *** [ompl/py-bindings/CMakeFiles/update_geometric_bindings.dir/all] Error 2
make[1]: *** [ompl/py-bindings/CMakeFiles/update_bindings.dir/rule] Error 2
make: *** [update_bindings] Error 2

I have seen some posts about this, but it's still not fixed...

Comments (6)

  1. Mark Moll

    Maybe you should remove the pyplusplus*.cache files and try again. I have never seen this error. One possibility is that you are running out of memory. In that case, you could copy the py-bindings/bindings directory from one of your other machines where you already have generated the python bindings.

  2. Yannik-kenzeler reporter

    I tried to install it again on my pc in a virtualBox with more RAM. installation was just fine again and i followed the same steps. I tried to compile it on the pc at work again, but it couldn't compile it (the same pc wich gave this error). It's an older pc so it just might be that problem

  3. Log in to comment