Regarding the

Issue #29 invalid
Fahad Islam
created an issue

the prints are:

Traceback (most recent call last):
  File "./", line 40, in <module>
    from ompl.util import OutputHandler, useOutputHandler, LogLevel
  File "/home/fahad/Downloads/omplapp-0.12.1-Source/ompl/py-bindings/ompl/util/", line 4, in <module>
    from ompl.util._util import *
ImportError: No module named _util

I have issue while starting my GUI. Error log is given above. The code which is creating error is:

    from ompl.util import OutputHandler, useOutputHandler, LogLevel
except ImportError:
    sys.path.insert(0, join(dirname(dirname(abspath(__file__))), 'ompl/py-bindings' ) )
    from ompl.util import OutputHandler, useOutputHandler, LogLevel

the last line is the line 40.

The issue is the same as discussed in one of the resolved issues, but I don't get it how it happened, the link with same issue is:

More is that I am not able to run the following Command

make update_bindings

the above command gives the following error:

make: *** No rule to make target `update_bindings'.  Stop.

Please tell what I am doing wrong.

Comments (19)

  1. Fahad Islam reporter

    as given in the instructions I ran the following command after "make installpyplusplus":

    cmake .

    The following log generates:

    -- checking for module 'ccd=1.4'
    --   package 'ccd=1.4' not found
    -- checking for module 'fcl>=0.2.4'
    --   package 'fcl>=0.2.4' not found
    -- CCD library not found.  Will download and compile.
    -- FCL library not found.  Will download and compile.
    -- checking for module 'assimp'
    --   found assimp, version 2.0
    -- Configuring done
    -- Generating done

    It says that ccd and fcl libraries are not found. Is it a possible problem?

  2. Arsalan Akhter

    @Fahad Islam I encountered the same problem. (There might be redundancy in the following solution, nonetheless,) worked around as follows:

    In the folder,

    ~/omplapp/build/Release/pyplusplus $

    please ensure that there are three folders and there contents are fully downloaded. If not, download them from

    gccxml :



    You may download them manually and extract them at the above mentioned path.

    Secondly, install pygccxml:

    $ sudo apt-get install python-pygccxml

    After that, cd to

    ~/omplapp/build/Release $

    and then run

    make installpyplusplus && cmake . 
    make update_bindings

    After built completes

    $ cd ~/omplapp/gui 
    $ ./

    It should run the GUI.

    Hope that helps.

  3. Mark Moll

    It's ok that libccd and fcl are not found. They will be automatically downloaded and compiled. It should not be necessary to install python-pygccxml if you typed "make installpyplusplus". After you typed "make installpyplusplus && cmake . && make update_bindings" do you still get this error?:

    make: *** No rule to make target `update_bindings'. Stop.

  4. surabhipandey88

    which ompl tar file u have downloaded? Are you following the steps given i mean untar the tar file in your home directory inside omplapp-0.12.2-Source(i have downloaded latest version i.e 0.12.2) create build/Release directory and follow the steps given in the instruction link.I was also getting same error cause i was creating again the directory ompl and inside that build/Release. Are you doing the same mistake?

  5. Fahad Islam reporter

    I have used the same version and I am creating build directory inside omplapp-0.12.2-Source directory. Followed the instructions as it is still getting this error

  6. Xin Li

    Hi Mark, The same problem happens to me too.

    I've successfully executed make installpyplusplus && cmake ., and

    gccxml --version
    python -c "import pygccxml, pyplusplus"


    But I still get make: *** No rule to make target \update_bindings'. Stop.`

  7. Mark Moll

    Maybe remove CMakeCache.txt and try again? Check whether cmake finds dependencies in the right places:

    grep PYTHON CMakeCache.txt 
    grep PYPLUSPLUS CMakeCache.txt 
    grep GCCXML CMakeCache.txt 
  8. Xin Li

    Hi Mark,

    Here is the output of grep.

    //ADVANCED property for variable: Boost_PYTHON_LIBRARY_DEBUG
    //ADVANCED property for variable: Boost_PYTHON_LIBRARY_RELEASE
    //ADVANCED property for variable: GCCXML

    Thanks a lot.

  9. Xin Li

    Hi Mark, I tried to rebuild the ompl, and resulted in the same error.

    I guess it's because I use python from homebrew instead of what system provides, and make installpyplusplus use the brew version of python, while cmake . detects py++ with system version.

  10. Log in to comment