Problem with ompl_app.py

Issue #52 resolved
Yuan Li
created an issue

Hi!

I can't start the gui using ompl_app.py.I got this error.

Traceback (most recent call last): File "omplapp/gui/ompl_app.py", line 42, in <module> from ompl import app as oa File "/home/administrator/omplapp/ompl/py-bindings/ompl/app/init.py", line 16, in <module> from ompl.app._app import * ImportError: No module named _app

Comments (8)

  1. Mark Moll

    This probably means that some of the dependencies for OMPL.app were not installed. Can you check whether you have Assimp, FCL, and PyQt4 installed? You can remove your CMakeCache.txt in your build directory and run cmake again. The output should look something like this (with different version numbers and paths):

    -- The CXX compiler identification is Clang 5.0.0
    -- The C compiler identification is Clang 5.0.0
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Building Release
    -- Boost version: 1.54.0
    -- Found the following Boost libraries:
    --   date_time
    --   thread
    --   serialization
    --   filesystem
    --   system
    --   program_options
    --   unit_test_framework
    --   chrono
    -- Boost version: 1.54.0
    -- Found the following Boost libraries:
    --   python
    -- Found OpenGL: /System/Library/Frameworks/OpenGL.framework  
    -- Found Python: /opt/local/Library/Frameworks/Python.framework/Versions/3.3/lib/libpython3.3.dylib  
    -- Found PY_OpenGL: /opt/local/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/site-packages/OpenGL  
    -- Found PkgConfig: /opt/local/bin/pkg-config (found version "0.28") 
    -- checking for module 'ccd=1.4'
    --   found ccd, version 1.4
    -- checking for module 'fcl>=0.2.7'
    --   found fcl, version 0.2.9
    -- Found assimp: assimp  
    -- Boost version: 1.54.0
    -- Found the following Boost libraries:
    --   python
    -- Found GLUT: -framework GLUT  
    -- Boost version: 1.54.0
    -- Found the following Boost libraries:
    --   python
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /Users/mmoll/build/omplapp/Release
    
  2. Yuan Li reporter

    I have another question. The gui can work now, when I cmake, the output contains this.I have downloaded ccd and fcl.

    -- checking for module 'ccd=1.4'
    --   package 'ccd=1.4' not found
    -- checking for module 'fcl>=0.2.7'
    --   package 'fcl>=0.2.7' not found
    -- CCD library not found.  Will download and compile.
    -- FCL library not found.  Will download and compile.
    

    Does this matter?

  3. Yuan Li reporter
    • changed status to open

    I have another question. The gui can work now, when I cmake, the output contains this.I have downloaded ccd and fcl.

    -- checking for module 'ccd=1.4'
    --   package 'ccd=1.4' not found
    -- checking for module 'fcl>=0.2.7'
    --   package 'fcl>=0.2.7' not found
    -- CCD library not found.  Will download and compile.
    -- FCL library not found.  Will download and compile.
    

    Does this matter?

  4. Yuan Li reporter

    Using the gui,when I chose the PRM or PRMstar planner, the window became no respond and can't get the path. I can't figure this out.

  5. Mark Moll

    Please open a separate issue for each possible bug. The message that FCL and DCD are download is not a bug (unless you are convinced you installed DCD and FCL yourself in the right place). Please open a new issue for PRMstar and describe in detail the steps needed to reproduce it.

  6. Log in to comment