__set__ raise TypeError('expected ' + str(self.expected_type)) TypeError: expected <class 'openpyxl.descriptors.base.String'>

Issue #1023 resolved
Pratyuma
created an issue

Hi, I am not able to load the workbook, getting the TypeError (see attached image). I can get the workbook to load with openpyxl version 2.4.11 as well as 2.5.0a2. However when I upgrade to version 2.5.0a3 it starts throwing the error. I also tried upgrading to version 2.5.2, however it was still giving the same error. I cannot share the xlsm file due to security reasons.

Thanks in advance. Pratyuma

Comments (6)

  1. CharlieC

    You'll have to debug this yourself if you can't provide a file. The problem is pretty clear from the traceback, it's related to one of the graphical objects in the file specifically something with a tooltip.

  2. Pratyuma reporter

    I was trying to load this try.xlsx when I was getting the error. Can you please guide me why I am getting the tooltip error?

    Thanks, Pratyuma

  3. Pratyuma reporter

    Thank you so much for the quick help. This change resolved the issue I was having. I am facing another issue with a different xlsx workbook. I will create a new issue for that.

  4. Log in to comment