Cannot convert numeric value to Excel cell

Issue #1229 resolved
burakcyildiz
created an issue

Python version: 3.7.1

When trying to write a numeric value to an Excel cell, I get the "Cannot convert {0!r} to Excel" error as follows:

openpyxl_issue.jpg

Note that this issue is not the case if I write the numeric after typecasting as string. I tried using integer and float typecasts without luck, and the dtype of the variable is definitely numeric, not a list/tuple/etc.

In addition, I tried running the same code on a different machine with Python version 3.7.0 and it worked without the error.

I can try fixing the bug if I understood where it is coming from. So far, I checked the source code in cell.py, and did not understand why it is not recognizing an integer or float value (as reported within Python) as a numeric.

Comments (2)

  1. burakcyildiz reporter

    Thanks for that. My apologies for the duplicate, I was not able to find that other issue. Got the latest source and that indeed solved the issue. Hopefully it will be pushed to the release version of the package soon as well.

  2. Log in to comment