Python 3.3 Support in openpyxl 2.5.0?

Issue #926 resolved
Samuel Lee created an issue

Hi, I saw an inconsistency in the

In Line 21 to 24:

if sys.version_info < (2, 7):
    raise Exception("Python >= 2.7 is required.")
elif sys.version_info[:2] == (3, 3):
    warnings.warn("Python 3.2 is not supported")

So, is Python 3.3 going to be supported or not?

Comments (2)

  1. CharlieC

    Thanks for the report. We will no longer actively support, ie. we do not test, Python versions that the PSF no longer supports and discourage people from using them. But we won't generally try and break them either.

    There are syntactical reasons why we explicitly block installing on 3.2 and 2.6: we'd rather let users know as early as possible that they cannot use openpyxl with a particular version of Python.

  2. Log in to comment