openpyxl Value must be one of set(...

Issue #952 resolved
Mauricio Júnior created an issue

The following bug: https://groups.google.com/forum/#!topic/python-excel/XUlhMnU4gvY

It was solved for the version 2.3, but it seems to be missed on later versions.

Comments (11)

  1. Mauricio Júnior reporter

    Hi. Thanks for your repply. Ad also, thank you so much for the work you've been doing on the lib. The file I'm working is attached. I've tried the 2.5 version as well as 2.9. Only the 2.3.9 works. All of them removes the charts.

  2. CharlieC

    I think support by for e-mail is somewhat limited: signatures, etc. won't be stripped and files not extracted.

    The problem is related to the use of a custom name for the table style Orçamento Familiar Mensal and should be fairly easy to fix.

  3. Mauricio Júnior reporter

    Do you know why charts are lost when I read the file? Special functions like =Renda[[#Totals],[Projetado]] are not being kept as well.

  4. CharlieC

    Please don't post multiple issues on a single report. You might also want to sign up to the mailing list to see the version announcements: read-support for charts was introduced in version 2.5

  5. Log in to comment