Clean up qrscu a little to aid field debugging

Issue #528 resolved
Ed McDonagh created an issue

For example see if we can close each association before opening the next one

Comments (44)

  1. Ed McDonagh reporter

    See also 91a8855: Terminated initial association after ehco instead of keeping it open. Better check of initial echo. More references to query_id in logging, but not completed. Refs 528

  2. Ed McDonagh reporter

    Moved tools import to after django setup to make testing easier. Moved _move_req to nearer movescu. Added max idle, not sure it does anything, can't see how to handle it. Refs #528

    → <<cset 5c0fd1e7419b>>

  3. Ed McDonagh reporter

    I don't think max idle works for a move association, so removing. Made Pending message more useful, reduced other messages to debug to reduce the noise. Refs #528

    → <<cset cf56e4689dd0>>

  4. David Platten

    Hi @edmcdonagh. Should I be able to drop the updated files into my live system to test this?

    As an aside, for my Toshiba CT RDSR creation routine to work I'll need to be able to retrieve at least two images from each series because the dose summaries consist of two images.

  5. David Platten

    @edmcdonagh, I've used the code from this branch to query my PACS.

    python D:\Server_Apps\python27\Scripts\ 1 1 -dx -f 2017-09-14 -t 2017-09-14


    python D:\Server_Apps\python27\Scripts\ 1 1 -mg -f 2017-09-14 -t 2017-09-14

    both worked beautifully, but when I tried

    python D:\Server_Apps\python27\Scripts\ 1 1 -ct -f 2017-09-14 -t 2017-09-14 -i "CT Chest High Resolution"

    I received the following error:

    Traceback (most recent call last):
      File "D:\Server_Apps\python27\Scripts\", line 14, in <module>
      File "D:\Server_Apps\python27\lib\site-packages\openrem\remapp\netdicom\", line 947, in qrscu_script
        study_desc_inc = map(str.lower, map(str.strip, args.desc_include.split(u',')))
    TypeError: descriptor 'strip' requires a 'str' object but received a 'unicode'

    Do you think this error may be because I'm running OpenREM 0.7.4 code everywhere except for your updated netdicom files?


  6. Ed McDonagh reporter

    No, from the error message that is probably due to the new files, and lack of testing of that element.

    I'm glad the non-text string tests worked nicely. I'll add a test if I can and fix the versions with the text.

  7. David Platten

    @edmcdonagh, I tried to use this new code to retrieve CT data from PACS, but it only fetches RDSR objects. Does it have a switch to make it fetch images too? I need to be able to retrieve images for the majority of our CT scanners. Thanks.

  8. Ed McDonagh reporter

    Are you trying to get Philips dose screens, or something else? What scanners are you after images from?

  9. David Platten

    I need to be able to get:

    • Philips dose screens from a Brilliance 64
    • Toshiba dose screens from an Aquilion CX and an Aquilion CXL. Dose screens from these come as a pair of images, so I need at least two images retrieved from each series
  10. Ed McDonagh reporter

    I don't expect it to work for your Toshiba extensions - that's the next job. Does it work for the Phillips? If, then I need to fix it!

  11. Ed McDonagh reporter

    None of the long -- versions of the flags are working, nor are multi-letter short - flags with strings. Not sure if it's something to do with this version of the code, or if it never worked.

  12. David Platten

    @edmcdonagh, I have just tested the code: 1 1 -ct -f 2017-09-22 -t 2017-09-22

    and 1 1 -dx -f 2017-09-22 -t 2017-09-22 -i "XR Abdomen"

    both worked as expected.

  13. Log in to comment