sigdig fails when value is an empty string

Issue #707 resolved
David Platten
created an issue

When calculating the accumulated total DAP and RP doses over x weeks for the first time after upgrading to 0.9.0b3 I received an error to say that the calculation had failed. Viewing the rf summary pages showed that values had been calculated. However, some rf summary pages failed with an error saying that sigdig required a float. Investigation showed that some values being passed to sigdig were empty strings.

I need to further investigate the original error that occurred when I first calculated the accum doses (this message has not reappeared since).

Comments (6)

  1. David Platten reporter

    I have tried to reproduce the original error by upgrading a backup of my 0.8.1 database to 0.9.0b3 and clicking on the "Recalculated cumulative doses" button. This worked perfectly without error on the Ubuntu system I tried it on. I need to repeat it on a Windows system.

  2. David Platten reporter

    I've just tried to reproduce the original error on a Windows system by upgrading a 0.8.1 to 0.9.0b3 and then recalculating the doses. It worked perfectly with no error.

    I think I must have interrupted the original calculation somehow.

    I think this is fine.

  3. Log in to comment