Commits

Joseph Walton committed fa60ee6

Require a 1.5 JDK to avoid breaking fragile tests.

  • Participants
  • Parent commits 3883a3f
  • Branches 2_2_6_maintenance

Comments (0)

Files changed (1)

             </plugin>
 
             <plugin>
+                <artifactId>maven-enforcer-plugin</artifactId>
+                <version>1.2</version>
+                <executions>
+                    <execution>
+                        <id>enforce-historic-jdk</id>
+                        <goals>
+                            <goal>enforce</goal>
+                        </goals>
+                        <configuration>
+                            <rules>
+                                <requireJavaVersion>
+                                    <version>[1.5, 1.6)</version>
+                                </requireJavaVersion>
+                            </rules>
+                        </configuration>
+                    </execution>
+                </executions>
+            </plugin>
+
+            <plugin>
                 <artifactId>maven-compiler-plugin</artifactId>
                 <configuration>
                     <source>1.4</source>